Shelly 2.5 calibration problem (is Shelly a good company?)

Hello,
I bought two Shelly 2.5 to be used with a couple of rolling shutter. I configured them and I can use them with HA via MQTT of course.
Unfortunately I was not able to complete the calibration procedure so I cannot use them completely giving the position too.
I got an error immediately after I start the procedure:

It looks that the procedure starts but the shutter immediately has a couple of hops/shakes and stop after few second while is rolling up.
I tried to write an email to the Shelly support and They answered sending a generic documentation about some check to do to be sure the device worked properly. Unfortunately They also invite me to use Messenger/Facebook but I do not have any account and don’t like to subscribe just to have support. I wrote back an email which stays without answer.

Did anybody have my same problem calibrating the device?
Did anybody managed to talk to the support without using Messenger or Facebook?

Thank You for your help in advance.

What fw version you have on the Shelly 2.5?

increase the Open/Close working time and disable the obstacle detection when doing the calibration, than you can revert it back.

Take a look at the power consumption when doing the calibration, just to note if there is anything strange.

Obstacle detection is disabled.
The firmware is:

20190531-075825/[email protected]

I set 120 secs while it normally takes maximum 15 secs to go from closed to open position or viceversa.
It looks to show regularly the power consumption while is moving which is around 230 W.
These are same checks that support told me to do.

You get the error, but the calibration goes on?

If yes, when it reaches the top or the bottom, what is the power measurement?

Yes, It looks that the calibration goes on despite the error.
When the shutter reaches the end or the bottom the power consumption drops to zero.

Of course when the shutter reaches the top is clearly full (100%) opened. When it reaches the Botton there is some lag due to full shutter unrolling.
So I can understand that it couldn’t be very accurate but if I set it to 50% that is how it looks like:

The percentage is related to the engine revs not to the roller shutter position. So you should find the right percentage for the position you need.

1 Like

A little bit awkward and pretty not intuitive but it sounds logic seen how the calibration works.
It would need the possibility to tell the Shelly when the shutter is “positionally” closed to really calibrate the position.
Anyway the error, even if it looks to be “cosmetic”, looks awful.
It remains to be seen why Shelly Cloud stopped giving support after to have sent a generic procedure.

Thank You for sharing your knowledge.

:grinning:

2 Likes

did you solve this issue since ? thanks

I have a far from good experience with buying directly from Shelly (Allterco). I pre-ordered their Dimmer SL, there was a huge Pre-Order Now button on their website. About a month later I received the wrong dimmer. They insisted that it was not on error on their site, the proof they sent was a screenshot of the product-page of a Door/Window switch. Communication is slow and they’re not really willing to solve the problem. Nice products, very bad customer service.

I have the opposite experience with Shelly (Allerco). One of the shelly 1 I ordered was defective. Flashed it with Tasmota, put it on my test-bench, everything was working. Put it in the wall, it was not working anymore. Removed it from the wall, put it on my test-bench again, was working. After looking at it, I discovered 2 of the wires did not fix well, no matter how hard I put on the screws. I emailed them, the same day they replied I should send it back. When they received it, I got a coupon for a new one, including the costs I had to pay to send it back. So I can’t complain about Allerco customer support.

I bought 3 times directly from Allerco. Never had problems. Received my goods always within 2 weeks (normal shipping, not express). All devices are working perfect. I use them for all my covers (with calibration) and for a few lights. Cant complain about shelly devices… i love them tbh.

I’m having a problem getting my shelly 2.5 to calibrate also. My shelly won’t complete the calibration because it over travels the door binding up the motor and goes into over wattage shutdown.
It would be nice if they added a manual calibration setting so you can choose where the door stops accurately. At the moment I’m using the seconds running setting but it eventually doesn’t close the door all the way.
I’m hoping they will figure out a better of calibrating motors.

There seem so be an issue with the shelly web ui and Safari on macOS. There is an error displayed directly after starting the calibration process. However, in my experience, the calibration still completes successfully. Try to use another browser to get rid of this issue.