Shelly 2.5 mqtt roller mode not detected

Good evening,
I have other sonoffs installed and working in HA.
Today I mounted a shelly 2.5 as a cover to control a roller shutter.
I added this code in configuration.yaml but it is not active.
I tried to install the shelly plugin in HACS and the schelly is detected.
The plugin detects it as CoAP and not as mqtt !!
Open, close, stop and consuption are detected.
Added to an entity card the control works but I can’t find how to use it in an automation !!

But why isn’t shelly 2.5 working like mqtt?
Do I have to mount the firmware to make it go into HA?

This is the code in cover.
Of course I changed the shelly name to mine.
My topic is like this:
shellies / shellyswitch25-xxxxxx / online
in the end I / online !! I don’t know if I have to put it or not.
I have however tried with and without but it does not go.

Some idea ?

Thanks, Alberto

- platform: mqtt
  name: Tapparella Cameretta
  command_topic: "shellies/shellyswitch25-00023B/roller/0/command"
  position_topic: "shellies/shellyswitch25-00023B/roller/0/pos"
  set_position_topic: "shellies/shellyswitch25-00023B/roller/0/command/pos"
  availability_topic: "shellies/shellyswitch25-00023B/online"
  payload_available: "true"
  payload_not_available: "false"
  qos: 1
  retain: false
  payload_open: "open"
  payload_close: "close"
  payload_stop: "stop"
  position_open: 100
  position_closed: 0
  optimistic: false

I would install MQTT Explorer and if the data is moving thou MQTT