Shelly BLU Motion is not found in BTHome

I turned on Bluetooth on a Shelly Plus 1 and activated BT passive mode in HA, but unfortunately the BLU Motion is not recognized. A Shelly BLU button and two BLUE door/windows sensors work perfectly in HA via BTHome. HA, Plus1 and the BLU Motion have the latest software installed. I can integrate the BLU Motion into the Shelly Cloud and motion is detected, but it cannot communicate with BTHome. Does anyone have the same problem or has an idea what else I could try?

1 Like

Same problem here but with a pro4pm instead. Would like to tap into the solution

I have the same Problem with multiple BT observer in Shelly App all is working fine but BTHome does not discover the Motion

From what I know from our Theengs Gateway Home Assistant Add-On, which also recognises and decodes the Shelly BLU Button1, BLU Door/Window sensor and the BLU Motion, I would say you definitely need active scanning mode.

I tryed it have some of my Observers in active and some observers in passive.
As i am not the only person having this issue i opened a bug in github for that.

I did mor research and found in the core.config_entries an entry with

  {
    "entry_id": "6aaf559ceda50b5636d2d595ff11ea60",
    "version": 1,
    "minor_version": 1,
    "domain": "bthome",
    "data": {	},
    "options": {},
    "pref_disable_new_entities": false,
    "pref_disable_polling": false,
    "source": "ignore",
    "unique_id": "B0:C7:DE:C5:2B:AB",
    "disabled_by": null
  },

which was my device mac address
i removed this entry from that file and restarted Home assistant then polled a new cycle on the device an auto descover now recognized the Sensor as new device via auto discover.

im not shure how this entry came to that file but for me this was the solution now and the device is now correct in the BTHome integration.

Hello Chris,
thank you for the advice. It was the same problem for me - I also deleted the block from core.config_entries - restarted HA. Everything is perfect, the device is found in BTHome.

1 Like

My problem is also solved. I updated the Shelly blue firmware and while pairing for the update HA autodiscovered the device.
Honestly I believe that simply repairing after setting the Bluetooth scan mode to passive has done the trick.