Shelly EM Power (kWh) always zero, but wattage (kW) reading fine - why?

I installed a shelly em in my garage consumer unit yesterday. One clamp on the garage supply, one on the specific circuit for the car charger.

Added it via the standard shelly integration. I see the realtime wattage sensors working fine, but the kWh sensors are always zero.

I know i could set up a hass utility sensor to log the kWh myself, but shouldn’t the shelly integration that provides the kWh sensors be working? Do i need to do something to make it work?

Thanks!

I have the shelly em on my AC and I get all the values. Any chance the clamp is on backwards and it is negative. This happened to me and nothing would show but 0 for the energy because it was negative. I also have to double everything as I am on split phase. I could have used both but would have to create sensors to add the two values together.

Screenshot from 2022-06-24 14-44-09

When I first installed I had a negative reading (from the shelly interface itself), so swapped the clamp around. Shelly and home assistant have been showing me positive amount of watts being used for both sensors, so I’m still baffled why no kWh data.

What do you see when you go to:

http://shelly_em_ip_address_here/status

Have you set up unicast in the Shelly device?

Yes I am using coiot unicast like your screenshot (my first shelly em, but i have a bunch of 2.5 relays etc)

Shelly /status shows:

{
   "wifi_sta":{
      "connected":true,
      "ssid":"VLAN100",
      "ip":"10.0.1.35",
      "rssi":-60
   },
   "cloud":{
      "enabled":false,
      "connected":false
   },
   "mqtt":{
      "connected":false
   },
   "time":"",
   "unixtime":0,
   "serial":7609,
   "has_update":false,
   "mac":"244CAB431B1E",
   "cfg_changed_cnt":0,
   "actions_stats":{
      "skipped":0
   },
   "relays":[
      {
         "ison":true,
         "has_timer":false,
         "timer_started":0,
         "timer_duration":0,
         "timer_remaining":0,
         "overpower":false,
         "is_valid":true,
         "source":"input"
      }
   ],
   "emeters":[
      {
         "power":58.77,
         "reactive":-92.09,
         "voltage":241.51,
         "is_valid":true,
         "total":0.0,
         "total_returned":0.0
      },
      {
         "power":3.05,
         "reactive":0.00,
         "voltage":241.51,
         "is_valid":true,
         "total":0.0,
         "total_returned":0.0
      }
   ],
   "update":{
      "status":"unknown",
      "has_update":false,
      "new_version":"",
      "old_version":"20210429-104036/v1.10.4-2-g9a159c1fb-release-1.10"
   },
   "ram_total":49600,
   "ram_free":35952,
   "fs_size":233681,
   "fs_free":157879,
   "ping_check":false,
   "uptime":40739
}

Ok so the Shelly itself has not recorded any energy:

It’s not a HA issue.

How much energy have you used?

Enough to register 0.1kWh yet?

Yes, I charged the car for a while yesterday, used plenty of power.

I’ve also tried the “erase energy data” feature and rebooted the shelly em, but no change.

I’m on the latest shelly firmware too.

Guess i’ll go and ask the shelly people what’s going on; will report back if I find a solution.

Thanks for your help :+1:t2:

That was going to be my next question.

Good idea.

Can your EM reach the internet?

See:

3 Likes

Ah! working after I set the Shelly to use my internal NTP server, since it does not have internet access.

After a reboot I can see it now knows the time, and is calculating total power usage :slightly_smiling_face:

Thanks!

1 Like