Shelly H&T Strategy


Using the Shelly Integration with the H&T ( battery device) has been problematic and I’m unclear as to what else needs to be done.

I bought a Plus Plug and an H&T device as an experiment to see if they could be used to control a heating device in a room. Adding the native Shelly Integration the plus plug was added easily. But the H&T is a different beast as it sleeps, like a cat in a field of catnip.

I’ve installed latest and even BETA firmware on the device. Finally adding it into HA I get the properties that I need and Bingo. it sleeps and does nothing again. IT’s been a full 24hrs with widely raging temperature that should trigger it awake, and it should be awake every hour and with it set to be mains powered … every 10 mins. But there are no more records in HA other than the original at setup.

I Imagine this is the issue that other posts talk of a web socket failure. The solution may there to have been to install the ShellyForHASS custom integration. Looking that, it claims it’s discontinued as it has been fully integrated into core HA.

The device itself has url setting, specifically under Actions. That value is empty. Was HA supposed to configure this? Should I and what with?

What am I missing?

The most common problems are documented here:

If the configuration is correct, the next causes can be related to:

  1. wifi / network quality (poor wifi signal, interference, etc.)
  2. low battery (I have personally experienced Shelly devices reporting 85% battery strength but when I measure the battery with a multimeter it is actually almost dead).
1 Like

Thanks. It seems my journey with HA as a container on a QNAP Container station has ended :slight_smile:

It seems new ports cannot be forwarded once the container is created. Such options seem limited. I have an HA Green on it’s way anyway so I won’t fight it.

I now have that HA Green and still no luck

I check the UDP port is open on HA and ShellyHT and nmap says it is

For both:
5683/udp open|filtered coap

There is only one subnet here so that’s keeping it simple.

The device is 3m away in plain sight of the router.
Router is 2.4Ghz only
Battery is over 90% ( i mean I bought it yesterday :slight_smile:
Manually waking the device provides no updated of readings
Triggering with a change - still none.
The device is many degrees away from the initial setup temperature

The HT may be defective. I would contact Shelly to ask for a replacement.

It seems GET webhook requests are now enabled. So I’m going to fight-on maybe a few more days and I’ll have this device working. :slight_smile:

Although the GET option for my webhook automation doesn’t seem to work :laughing:

That’s a different post.

Have you tried enabling debug in the logger to see if there is any additional info?

  default: warning
    homeassistant.components.shelly: debug
    aioshelly: debug

I have a Shelly H&T Gen3 and a similar problem, but I can see that it is not related to Wi-Fi because the Shelly App shows the latest reading at Today’s 1 p.m., and at HA, I saw yesterday at 10 p.m., so I can say that at least Wi-Fi is not a problem.
Could it be the traffic between the device and HA? Yes, but I doubt it. I will try to enable debugging, as @MaxK said, and see if we can see something else.

Does anyone know how the data is pushed to the cloud? Is it directly calling their backend, or do they rely on our phone to send the data to the cloud?


Also, enable debugging via the Shelly integration: