Shelly Integration: authentication error

I’m a little bit confused about the Shelly integration.
I configured the integration in the HA config panel:


Unfortunately I got this error:

(Poll status) [pyShelly] Error, 401 Unauthorized http://<my_shelly_IP>/status

I can understand that there is something wrong connected to the user login to the shelly device ( I changed the default admin login fo course).

The only place where I found some user credential is this one below:

and I can confirm that the password is the right one.

I can’t understand what is wrong.

Any help will be appreciated


Have you gone to the IP address of each shelly and set the COIOT to point to your Home Assistant IP address with the port - so example

You can control alot of things from the Shelly IP Address including the name.

Ops I forgot that config.
Anyway I just made the required changes and restarted the device but it looks I got same error.

Since this config is in place are still needed the lines in the config.yaml?

Did you set the wifi mode - client? It will have SSID and password to access WIFI Lan.
Did you update the firmware if needed? It is in settings.

Are these motion sensors? If they are you have to config COIOT in actions also. Same ip address and port.

You do not need to configure anything in configuration.yaml.
Aren’t you using a second integration that is possible via HACS?
Yes, as mentioned in the previous post: update the Shelly device

Yes I can correctly browse the device with firefox or any other browser after logged in.
Tha firmware is up-to-date.
The integration (the old one) worked correctly.

it looks that the lines of the old config left in the configuration.yaml created some problem.
After removed them it looks all right now

Thank You for you help