Shelly Integration - Detached switch not working

Hi all

Using the built in Shelly integration for HA with Shelly 1 devices and trying to get detached switch mode working. For some reason, most of the sensors on the Shelly devices are disabled and unavailable. Wondering if anyone has any idea why (looking to use the _input binary sensor in automations controlled by the switch)

In Configuration, if you go to Integrations and look at the Shelly one, you should see one or more Shelly devices, if you have added them. Click the one you want, then you’ll see a number of entities associated with that device. Click the entities link and it will take you to the Entities page of the portal. (actually the entities you see here are not visible via the normal Entities page route until they are enabled…) Click on the entity you want to enable and flip the switch in the resulting dialog. After a bit, this entity will now be visible the normal way and useable in a template for a detached switch.

I have seen though (why I was searching and found your question this morning) that sometimes these entities become disabled, not sure why - I had to re-enable mine for the detached switch template to start working again.

image

1 Like

Almost feel embarrassed it was that easy. I’m sure I tried that in the past but it just worked for me.

Thanks very much!

That said, the update on that sensor seems extremely slow, about 15 seconds from changing the switch position

Did you get it running and can you please tell us how?

Im struggling with automations using the input sensor state tu trigger on/off of a smart bulb.

I switched all of my Shelly’s to MQTT quite a while back. I found the native integration to be flakey on my network.

Sorry if that question sounds stupid, but does that matter? :smiley: YOu stil have to automate your detached switch shelly right?

Yes you are correct. I still have automations to control what the detached switches.

I essentially have a MQTT binary sensor for the switch like this:

binary_sensor:
  - platform: mqtt
    name: "office_light_switch"
    state_topic: "shellies/shelly1-a1a1a1a1a/input/0"
    payload_on: "1"
    payload_off: "0"
  - platform: mqtt

Then my automation uses the toggle of this trigger as it’s trigger, and in turn the action is to toggle the relevant light entity.

@mehstg did the move to MQTT resolve the random unavailability of shellies for you?
I’m banging my head to underastand whether it’s an HA issue, a Shelly device issue or a WiFi coverage problem…

In my experience I’ve tried Shelly for hass, the native integration, and MQTT. MQTT all the way. Use the discovery script GitHub - bieniu/ha-shellies-discovery: Script that adds MQTT discovery support for Shellies devices. It’s rock solid and instant.

1 Like