Shelly integration - Shelly Door 2

Recently installed two Shelly Door Window 2 - Wi-Fi-operated Door/Window sensors. They all work perfect, this means that also my automations based on these sensors work seamlessly.
However, recently installed a 4th one. This one is all the time unreachable, until the door is actual opened and it comes on line. The result is that it comes alive too late for starting an automation. All sensors are set equally.
What do I wrong or is there something with the sensor?

If the other three units are working normally, I would suggest check your ColoT configuration on the troubled unit by waking it up (via button or by battery remove/replace) and then logging in to the shelly device web page and checking the ColoT settings. port 5683 at the HA URL.

If that is straight I would consider a static IP address for the unit instead of DHCP, as this can delay slightly while it negotiates DHCP.

I have several Shelly door/window wifi and some bluetooth door/window sensors from Shelly, all working flawlessly, except for the bluetooth sensors showing Unavailable after HA reboot until door is opened or closed. About 130 total Shelly devices on the HA platform.

I originally set up a lot of automation on the Shelly devices themselves to insulate against any HA troubles, but HA has been much more reliable over the months than the on-device programming.

I had issues with Shelly relays going offline and I implemented just that - the Coiot and also making them all static IP addresses. For those that do not have Coiot settings on the web page for the device, set up outbound websockets (Settings->Enable Outbound Websockets, then the settings are “Default TLS” and the server to enter as below replacing %your HA instance IP address% with the actual IP):

ws://%your HA instance IP address%:8123/api/shelly/ws

I only have 16 shelly devices - but I did that about 9 months ago and I have never even once had any of them go offline (and one of them connects to an access point that is in a room in a separate building)!

Thought I has set CoIoT. Seemed not to be. Thanks

1 Like

In no Enable Outbound Sockets can be found. However I have set already CoIoT. Thought I had done that already.

From what I understand they only have one or the other, the newer devices (+) have the outbound websockets

1 Like