Shelly Plug S energy comsumption


I’m trying to use my Shelly Plug S for energy tracking with the latest Tasmota firmware, but even if I use the assumed good template my W and consumptions fields are empty. Are there any other steps required to enable energy tracking? I’m using the following template for this device and my screen looks like this

{"NAME":"Shelly Plug S","GPIO":[321,1,320,1,0,2720,0,0,2624,32,2656,224,0,4736],"FLAG":0,"BASE":45}

My Tasmota UI looks like this


I suppose maybe energy calibration missing (but I can’t figure out from the docs) or maybe my template is not perfect

So, what do I miss here?

Thank you