Shelly Plus Smoke - Silence Alarm

Shelly Plus Smoke can be integrated in HA and actions can be triggered when smoke is detected, however there is no option to silence the alarm from within HA.

It would be nice to have a service available within HA to silence the alarm of the Shelly Plus Smoke.

It is available in the API so it could be added.

Until that happens you can do this:

Update this shell command with the ip address of your Shelly Smoke:

configuration.yaml file

  mute_smoke_alarm: curl -X POST -d '{"id":1,"method":"Smoke.Mute","params":{"id":0}}' http://ip_address_here/rpc

Used in an automation:

  - service: shell_command.mute_smoke_alarm

Can also be used as a dashboard button tap action.

type: button
show_name: true
show_icon: true
  action: call-service
  service: shell_command.mute_smoke_alarm
entity: shell_command.mute_smoke_alarm
1 Like

Nice, thanks :upside_down_face:

Also check the device page in Settings → Devices & Services → Shelly. It may have disabled controls you can enable.

I enabled the more usefull. Tomorrow i will test the button to mute the alarm. I need to burn some paper :rofl:

I tried the smoke sensor and the button to mute the alarm worked perfectly.
I set up a priority fire alarm to notify the mobile phone and it works perfect too.

  - alias: "Fire Detected Android alarm stream"
      - platform: state
        entity_id: sensor.smoke_alarm
        to: "smoke"

      - service: notify.mobile_app_<your_device_id_here>
          title: "Wake up!"
          message: "The house is on fire and the cat's stuck in the dryer!"
            ttl: 0
            priority: high
            channel: alarm_stream
1 Like