Shelly PM Mini readings not showing. Should it work?

Hi all,

I have recently started using Shelly gear and everything has been working fine with gen 1 devices like plugs and relays. But when trying the Shelly Plus PM Mini (gen 2) to just measure consumption, I´m having problems with the relevant entities not showing up in Home Assistant. (I only get the reboot and firmware upgrade etc).

I run the devices on a separate VLAN from Hass and multicast is not an option which means that I have to add the devices per IP and set the ColoT for gen1. For gen 2 I am using the outbound websocket which seems to be working fine.

Looking at the logs, the values are reported in from the PM so what do I need to do to get it all the way with the Shelly integration?

From the logs:
2023-11-10 21:21:15.173 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] recv( {‘src’: ‘shellypmmini-6055f99ace20’, ‘dst’: ‘aios-2584432208’, ‘method’: ‘NotifyStatus’, ‘params’: {‘ts’: 1699647675.19, ‘pm1:0’: {‘id’: 0, ‘apower’: 1937.1}}}
2023-11-10 21:21:15.173 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] Notification: NotifyStatus {‘ts’: 1699647675.19, ‘pm1:0’: {‘id’: 0, ‘apower’: 1937.1}}
2023-11-10 21:21:15.173 DEBUG (MainThread) [homeassistant.components.shelly] Manually updated 00010401PM data
2023-11-10 21:21:15.176 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] recv( {‘src’: ‘shellypmmini-6055f99ace20’, ‘dst’: ‘ws’, ‘method’: ‘NotifyStatus’, ‘params’: {‘ts’: 1699647675.19, ‘pm1:0’: {‘id’: 0, ‘apower’: 1937.1}}}
2023-11-10 21:21:15.176 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] Calling WsRPC message update for device id 6055F99ACE20
2023-11-10 21:21:15.176 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] Notification: NotifyStatus {‘ts’: 1699647675.19, ‘pm1:0’: {‘id’: 0, ‘apower’: 1937.1}}
2023-11-10 21:21:15.176 DEBUG (MainThread) [homeassistant.components.shelly] Manually updated 00010401PM data

I have added two devices with shipped fw v1.03 and the newer 1.08. Same behavior.

Any help appreciated.


I had the same issue. I just went into the (new) Shelly app and messed with the network settings, activated the range extender and bluetooth (and possibly something else) and then the power and energy values showed up in the UI.

I have a BLU Motion PIR connected to this device and can’t yet figure out how to get that into HA but working on it…

Having the same issue, whereas my gen2 1 (just switch no measuring) is working fine. Therefore I assume it is not clearly identified in HA.
Who can provide some insights?
Did some surface investigations and only see responses from the PM which carries pm1:0 aenergy but not the voltage and power information.
Everything is fine in the webserver of the shelly and I nearly changed every setting, like indicated by @blaine but without success. Difference is, I have not used the app, but I would really be surprise, if this causes the difference.

Deleting is not forgetting in the internet… :smiley:
Nevertheless, thanks for sharing your feedback, that is is working for you.
I still see the difference, that you are using the mini1pm which comes along with the switch AND the measuring function. Whereas my and the thread initiators device is a PM only.
Schöne Grüße :smiley:

1 Like


When using the test script provided on github for the aioshelly python module, I see all the entries, I would like to see in HA as well…

In the logs (debugging was enable for a periode of time) I just saw:

2023-12-03 20:39:00.190 DEBUG (MainThread) [aioshelly.rpc_device.wsrpc] recv( {'src': 'shellypmmini-6055f9994dbc', 'dst': 'ws', 'method': 'NotifyStatus', 'params': {'ts': 1701632340.17, 'pm1:0': {'id': 0, 'aenergy': {'by_minute': [0.0, 0.0, 0.0], 'minute_ts': 1701632339, 'total': 0.0}}}}

and the device is just giving me 6 entities, among which some are coming from the fritzbox integration and others are trivial (reboot, uptime, fw-update, …)

In the meantime I noticed that the aioshelly component used in the installation of my HA instances is kind of outdated. It doesn’t list the device I am using in the list of shellys in
Quick trial of adding it simply to the list, didn’t brought any improvement - what a surprise.

Go to shelly device settings (which is acting as Bluetooth gateway ) and tap configure and choose passive checkbox. BLU Motion PIR device will appear after some time.

Got the other entities added now by upgrading to 2023.12. :slight_smile:

Might be this one: