Shelly PRO 4PM: Cannot add with official integration

I have a Shelly PRO 4PM and once adding it through the official HA Shelly integration I get no output in the interface (when using the IP host)

Upon inspecting the network request I can see the following error pops up:

"type": "abort", 
"flow_id": "18f73c40f6c71056e27903e1156bb2c7", 
"handler": "shelly", 
"reason": "already_in_progress", 
"description_placeholders": null

I have 4 other Shelly devices (no 4PM but 3EM etc) and all work just fine. I’m not sure what is wrong with the 4PM, I tried a factory reset and updating to the latest firmware( 0.10.1) but nothing seems to work
I am on. HASS 2022.5.3.

Any ideas on what is the issue?

PS: Integrating the HACS Shelly integration is not an option as I have a lot of other entities already configured and that one will override them all (Already tried that)

@max101 Did you fix this yet? I am guessing because the Pro 4PM is so new on the market it doesn’t actually seem to work w/ the builtin Integration?

Hi, no it does not work unfortunately. I ended up switching to the Shelley community (Shelly For Hass). That one supports it pretty well.