Shelly Pro 4PM problem with core-2022.2.6

I’m trying to connect a new Shelly Pro 4PM to the Home Assistant but cannot see the device.

I found this error from the log. This occurs every time during restart HA. I use core-2022.2.6 and supervisor-2022.01.1.

Logger: homeassistant
Source: components/shelly/
First occurred: 12:03:27 AM (1 occurrences)
Last logged: 12:03:27 AM

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/", line 74, in _async_process_pending_flows
    await gather_with_concurrency(
  File "/usr/src/homeassistant/homeassistant/util/", line 185, in gather_with_concurrency
    return await gather(
  File "/usr/src/homeassistant/homeassistant/util/", line 183, in sem_task
    return await task
  File "/usr/src/homeassistant/homeassistant/", line 203, in async_init
    flow, result = await task
  File "/usr/src/homeassistant/homeassistant/", line 230, in _async_init
    result = await self._async_handle_step(flow, flow.init_step, data, init_done)
  File "/usr/src/homeassistant/homeassistant/", line 325, in _async_handle_step
    result: FlowResult = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/components/shelly/", line 210, in async_step_zeroconf
    self.device_info = await validate_input(self.hass,,, {})
  File "/usr/src/homeassistant/homeassistant/components/shelly/", line 67, in validate_input
    "model": rpc_device.model,
  File "/usr/local/lib/python3.9/site-packages/aioshelly/", line 215, in model
    return cast(str, self.shelly["model"])
KeyError: 'model'

Can you reach the device with a browser using ip-address or dns name?

Yes, I can manage it via browser normally.

Try removing the device integration and re-adding it.

Done. Nothing changed. I also removed all other Shellies.

I tried to add second Pro 4PM. Home Assistant found it immediately. So, I will try to reset first one to factory default settings and try again.

Another PM4 works. It seems to use firmware version: 0.9.2-beta2.

This first one problematic device uses firmware version: 0.10.0-beta2. I have also tried to use it with firmware 0.9.3, without luck.

Last resort, do factory reset to make sure some random setting isn’t messing it up. Also make sure it isn’t a network problem; like overlapping ip-addresses or dns names.

Both of them has been done before made this post. Tested also different IP addressa and Wifi / LAN connectivity. I created support ticket to Shelly but didn’t get answer yet.

Did you get it to work?

Not yet. I have reset and reset and tried all tricks. Second one works but this one not.

It works now with HA via MQTT but not with native integration and it doesn’t connect to Shelly cloud too.

I have discussed with Shelly support in a support ticket but they tell again and again same factory reset instructions. Nothing new. I would like to be absolutely sure is this trusted solution for build my home automation or not.

I have 3 of these in my home, and they all work flawlessly. The only thing I dislike is that all 4 relays need separate inputs but they must be on the same phase. Since they are connected, it’s hard to combine with residual current protection. It’s limited to either all or none. Otherwise this is an excellent device. I love the ethernet connectivity. BTW I have no idea what protocol the home-assistant integration uses for this device. Do you?

Native integration uses CoIoT. There are more information about the integration Shelly - Home Assistant.

I have now tested with MQTT and it has been worked fine but today I update Home Assistant to version 2022.3.1 and it stopped to work with Shelly. There are some problem to get status information from the devices now. (but this is separately problem with my original question)

Hey I also have a Shelly PRO 4PM and once adding it through the official HA Shelly integration I get no output in the interface (when using the IP host)
Upon inspecting the network request I can see the following errors when addyng

"type": "abort", 
"flow_id": "18f73c40f6c71056e27903e1156bb2c7", 
"handler": "shelly", 
"reason": "already_in_progress", 
"description_placeholders": null

I have 4 other shelly devices (no 4PM but 3EM etc) and all work just fine. I’M not sure what is wrong with the 4PM one, I tried factory reset and updating to latest firmware( 0.10.1) but nothing seems to work
I am on. HASS 2022.5.3.

Any ideas what else to try?