Shelly Pro3EM Integration problem since last update(s)

Hope someone will be able to help me out.

Anyway I have Shelly Pro3EM integrated into HA (2024.1.2/11.3) for over a year and since last update(s) (unfortunately I cannot recall which one exactly triggered this) Core/OS I cannot get any readings from Shelly which until then worked just fine. Pro3EM is integrated but with error “Failed to set up.”. But it is working just fine as I can access it without nay problems via web interface.

I tried enabling/disabling/rebooting 3EM Pro and when I tried integrating/installing it again I get an error that my firmware version is not supported - it requires FW version 1.0+ and I have 0.11.99.
FW update via Pro3EM’s web interface returns I have the latest available firmware installed.
I’ve tried searching for adequate FW on but I couldn’t match any of the markings with Pro3EM.

Hope someone can help me out. Thank you in advance.

You may want to log an issue on GitHub:

And/or restore to a previous backup until you get this resolved.

I managed to solve the problem.
Seems like Shelly has a very profound way of accessing WAN and it actually (at least for me) requires STATIC IP.