Shelly Pro4PM not be added as light

I have a problem with a shelly Pro4PM. It’s on FW 0.12.0
Changed the “Appliance Type” of all 4 Channels to “Light”.
Boot up a fresh HAOS VM an added the device via the Shelly Integration. All 4 channels show as a switch, not as a light.
I also have a Shelly Plus1 with latest FW (0.12.0) and the same issue.
Any ideas?

tried another Shelly Plus1 with latest FW (0.12.0) and a fresh HAOS installation, the shelly still not be recognized as a light :frowning:

found an existing issue on github:

Seems to be a problem with the latest firmware.

I got the same problem and agree, its some confusion with the firmware 0.12.

My workaround (with 0.12) is to set the appliance type to Light via the Shelly Android application.

When I used the Shelly device before firmware 0.12, it worked perfect in HA. After upgrade to 0.12, I noticed in the web-interface of device, the appliance had been reset to General so I adjusted it to Light. It still worked in HA.
Some times later I added a Shelly device but now directly updated to 0.12 and adjusted settings from web-interface. This included setting appliance to Light. When including this device to HA it was, to my annoyance, set as a Switch. Yet later I discovered that the Shelly Android app viewed the last device as a General appliance, despite its web-interface still views it as Light.
I tried my workaround (above) and HA reacted correctly by changing the device to a light.
It seemes like there is a new appliance setting controlled by the web-interface and a old setting still in use by HA and the Shelly Android app.


As a workaround you can set consumption_types directly via device RPC with curl. You just only need a device IP
curl -s -X POST -d '{"id":1,"method":"Sys.SetConfig","params":{"config":{"ui_data":{"consumption_types":["lights","lights","lights","lights"]}}}}' http://<DEVICE_IP>/rpc

then you need to reload Shelly integration or restart HA.

This will set all appliance types to “lights”.
This will work with Shelly Pro 4PM. I don’t have any other gen2 devices to test :frowning: