Shelly Unavailable


A few weeks ago I saw a post in the release notes of HA 2022.9 that somebody has issues with shelly becoming unavailable.
I didn’t saw this issue with me but I payed more attention on it.
I suddenly when playing arround with my lovelace I saw a shelly going unavailable.
After checking more, I found out I have this on almost all of my shelly devices.
I also changes the Coiot from multicast to the IP of my HA but this doesn’t affect it.
Does other people have this issue with shelly products.
I have this issue most on my shelly plug s.

With 2022.10.1 I noticed my dashboard with firmware update sensor became unavailable.
The rest of the functionality is not affected, also not with the previous releases in September….

I have not investigated properly yet.

Same here, firmware update sensor are unavailable, but all the rest is working fine.

the unavailable thing is only very short, it’s just a few seconds and after that it’s back
I could see it in the backlog that it went unavailable.
For me everything goes unavailable not only the firmware update sensor.

The entity type of the “firmware udpate” changed. Refer to Shelly migrate to update entity (#78305).
Before it was of type binary_sensor and now of type update. So you have to replace all the binary sensors with the update sensors. Remember to activate the sensors before.

I just noticed. All Shelly devices are acting weird flipping between ‘last state’ and ‘unavailable’ every few seconds!!

Both HA and Shelly devices have the latest updates.

01 HA version

Any one facing the same problem? any solutions?


Just happend to me (yesterday same thing happend with other shelly at home)

Same here, all shelly devices randomly become unavailable! Wifi in my house is strong enough and I have a dedicated SSID only for IoT devices, so is not that the cause.
CoIoT is already set to unicast and all the shelly are on the latest firmware v1.12.1.
I’ve experienced this bad behavior in almost the last 2-3 versions of HA. Now I’m running the latest 2022.11.1 and I’ve not seen any improvement.

I also have 2 shelly plug s devices that become unresponse at all even with the shelly app.
I got 2 replacements but I’m wondering if this is related to it.

After some tests I’ve finally found the culprit. It seems related to the entity “firmware update”. If this entity is enabled shellies get randomly unavailable. So I’ve disabled both the “standard update” and the “beta update”.
Probably still bugged. Not a big issue, I check the updates manually.

Ok good to know this.
Going to try this and see if it’s fully solved in my HA.

Mines were disabled… and still the same.

Wifi signal is good (3 green bars)

I have around 50 Shelly devices connected to my HA 2022.12.3, all with Firmware Update enabled (and using this to keep the shellys with latest version) and everything is working very solid.
I have Shelly 1PM, Shelly Plus 1PM, Shelly 2.5PM, Shelly Plus 2PM and Shelly Dimmer 2… All working fine.

Try to share more info about your devices so maybe we can find a pattern on the issue.

1 Like

for now,it seems a problem with 3 devices with my wifi. (I have arround 20 and only are failing on those 3)

Good RSSI… i’m asking at shelly support group.

1 Like

I had the same issue with shelly devices becoming unavailable and found the cause for me.

It turned out that dhcp leases were gone after replacing my router. This caused all devices to get a random new ip. Since i’m using mqtt this should not be a problem imho, but it is.

To fix it i statically changed the ip of each device to the ip known to home assistant. You can find it by going to the device page. The button “VISIT” poits to the expected ip of the device.

1 Like

Good point. I have static IP on all my Shelly devices (and also some other devices on my network) and they are all working fine…

Same issue here:

  • Three Shelly 2.5 devices.
  • All three connected to the same Ruckus R320.
  • One is not reporting any issue and its also the one with the lowest signal strength.
  • The two others have the random “Became unavailable”.
  • The time they are unavailable is always 33 seconds.

Update: seemed that the two Shelly’s which were going unavailable were not configured to use “CoIoT”. changed the settings in the Shelly under the “advanced - developer settings” and seems to have fixed the issue.

Hi all. I a having the same problem.


  • Using DHCP
  • Dedicated IoT VLAN and WLAN, good RSSI
  • CoIP set to unicast (home assistant server)
  • Has been working for over a year.
  • Shelly 2.5 (gen1) device, with latest firmware as of today.
  • Same configuration as roughly 15 other shelly gen1’s, including 5 other 2.5’s.

Device becomes unavailable, and remains unavailable (not able to reach the internal webserver).

Briefly disconnecting the mains power to the shelly device makes it available again almost instanly.

What I find interesting is that the connected lights (shelly is in detached mode, using mqtt to control always-on zigbee light bulbs) flicker (turn off/on) even though the shelly remains powered. Even when the shelly is unavailable, and unreachable, the lights keep power after the flickering.

What did shelly support say?

Any new about this problem???

It´s annoying…

if annoyed enough, switch to mqtt.