Shellyforhass, Shelly button1

I install the shellyforHASS through HACS and then some relays (Shelly1 and Shelly2) . NO problem there. I even managed to install shelly button1 when they are ‘awake’ through USB supply. I was able to put automation in place based on trigger “switch turned on” but Home assistant don’t recognize the trigger when the button is not supplied through USB (sleep mode). in logbook, the button is unavailable.
Do someone already have the same problem? How do you solved this? Or can you help to imagine a workaround to be able to launch a script to turn some shelly relays ON based on a push on the button?
It’s working through the shelly app without problem but is restricted to shelly products!

Thanks in advance for your appreciated support.


Yep I’m just in the process of testing mine (Shelly Button 1) now and i’m having the same issue. I’ll update with my progress.

– Edit: So i’m not sure why yet but they have both started working reliably via MQTT at least

I received my first two button1’s yesterday and did some quick testing. They send their status updates using multicast. In contrast: MQTT uses regular unicast packets.
I’ll do some more testing over the weekend.

I started with running the latest firmware on the first button, but it seemed 1.8 wasn’t support yet. At least, according to StyraHem github
Now when running 1.7.3 I have exactly what you have @Riquet.

The Shelly developer replied on Facebook :

Has anyone been able to get the Button 1 to work properly with ShellyForHass? So far I haven’t had much luck yet, neither with battery or usb power. Initially I thought the issue was that they were in different VLAN than HA is in, but event within the same network they don’t seem to work properly. I hardly see any state changes and for some reason it seems the event most of the time doesn’t do anything when the button is pushed.
Would love to hear other’s experiences and especially if someone got it to work with which settings/setup (settings of the device, settings of ShellyForHass, …).
Thanks in advance.

Well, yes it works. But it responds slow. I also have it running in another vlan. Seeing your username I’m assuming you’re Dutch. You can pm me for additional information. In Dutch :slight_smile:

Thanks for the offer, but for know I’ve used mqtt instead for these buttons, it seems that’s actually working quite fast. As I use them really to trigger things anyway, mqtt fits very well.

PS: Belgian actually, so Flemish :wink:

Flemish is also fine :slight_smile:
I’m curious, what is the approximate response time between button press and actually receiving it in HA?

With MQTT? If it’s powered via usb it’s almost instantaneous. On battery power I would say about 1-2s, which makes sense as it first needs to connect to the WiFi each time before it can send the mqtt command. But for my purposes this works very well actually.

I’m also trying to get the Button1 working in ShellyForHass. I can’t work out how to listen for it. I have tried listening to *, but I don’t see anything relating to the button.

I have the same issue. They show up as devices they are not connected to any entities. Anyone know how to set it up correctly?

Hi all,

I know this is a old topic. but I found this topic very helpful. and you only need the mqtt broker.

read the topic and i found the post from [Tobias Perschon] very helpful.