Should I be able to see port 80?

Tags: #<Tag:0x00007f327bcdd7c8>

When I go to canyouseeme.org and check port 80 I can’t see it, even though I have it forwarded to my HA machine with my Unifi Security Gateway. I also have 443 forwarded to 8123 and can see that fine when I do a check. I’ve called comcast to see if they are blocking 80 and they said it is not blocked.

I ask because I’m having issues with Google TTS and setting up the manual integration of Google Assistant. When I try to send a TTS to one of my google homes, I can hear the speaker activate but none of the TTS actually plays. When I try to connect my google home app on my phone by adding the new device I’ve set up I just get a 404 error. I’m wondering if any of these issues have to do with port 80 and have been banging my head against the wall on these for some time now.

Just trying to figure out if the port 80 could be an issue or not. If so can I just change the port in HA and then where else would I have to change it? Obviously in my router port forwards, anywhere else?

This is my config.yaml entries:

http:
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Text to speech

tts:

  • platform: google_translate
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    base_url: xxx.duckdns.org
    service_name: google_say

google_assistant:
project_id: g-assist-integration-for-XXXXX
service_account:
private_key: “-----BEGIN PRIVATE KEY-----xxxxxxxx-END PRIVATE KEY-----\n”
client_email: “[email protected]unt.com
report_state: true
exposed_domains:
- switch
- light
- camera
- scene
- sensor
- script

Cannot validate your configuration, as you didn’t use the “code formatting” (</> icon) and I don’t want to guess indendation, but - by default, Home Assistant does not open port 80, but 8123 only. And it’s not using TLS encryption unless configured to do so.

See http integration for details.

Okay, so let me ask it this way. Since I have SSL working fine and can see my server on that port and login to it remotely, do I even need to worry about port 80?

Also, what could be the issue with my Google Assistant giving me a 404 : Not Found error when I click on my [test] Home Integration? I’ve tripple checked the settings from multiple sources, including the official instructions and various video tutorials including JuanMTech.

And any ideas about the TTS issue?

Go and fix your code, no one can tell.

I’m sorry for my ignorance, but that’s what I’m trying to figure out. I don’t know how to code and have basically just been copying tutorials and inserting my own duckdns and port information. I don’t know what you mean by the “code formatting” (</> icon). can you give me an example?

Read this: How to help us help you - or How to ask a good question

Example

I used this button from the editor‘s toolbar: Bild

Is this better?

# Text to speech
tts:
  - platform: google_translate
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    base_url: https://xxxxxxxxxxxx.duckdns.org
    service_name: google_say
google_assistant: 
  project_id: g-assist-integration-for-xxxxxx
  service_account:
    private_key: "-----BEGIN PRIVATE KEY-----xxxxxxxxx==\n-----END PRIVATE KEY-----\n"
    client_email: "[email protected]unt.com"
  report_state: true
  exposed_domains:
    - switch
    - light
    - camera
    - scene
    - sensor
    - script

yes it certainly is :slight_smile:

Now that the code is readable, does anyone have any ideas?

forwarded it to what port on your HA machine?

what is runninng on the port you forwarded 80 to?

I see it in my let’s encrypt configuration where it says “Only needed to http challenge”. not really sure what this is for. My main concern is trying to figure out why my TTS doesn’t work and also how to get the free version of Google Assistant working. I feel like it may have something to do with the SSL.