Should I transition to

HA has all of the components I need for the projects I have planned. And in future if it doesn’t have them il develop them :slight_smile:
Goal is projects which just involve a pi zero and Hassio as this makes it much easier for others to reproduce

Possibly not then if nobody is able to come up with a compelling reason for you to switch.

If you’re an advanced user with Linux skills and an existing working setup, there’s no need, especially if you want to tinker with your install. is more appliance-oriented for people who need a black-box sort of setup.

1 Like

What I like about it, my Linux skills being copying verbatim what someone tells me to type, is I can add functions outside the core of Home Assistant to the same Pi without fear of buggering up my working HA and perhaps even more importantly uninstall them easily if i don’t like/want them anymore.

Still got the charms of yaml to deal with obviously, so not quite black box, but I’m fine with that and it still lets me feel I’ve achieved something when changing the config.

Previously I used other devices to run things like dasher and the Google Assistant sdk for the reasons above but no more. Only downside to me is that it relies on someone producing an add-on for the function I want to add but I’m confident virtually everything will be added over time.

1 Like

You can always user another SD card and see how it works and swap back if you don’t like it.


maybe I’m late to this thread, but over the weekend I migrated my customised hassbian installation to in less than an hour.

Things I used in hassbian:

  • A bunch of HA services like weather etc
  • GPIO switches
  • Z-Wave (USB Aeotec)
    • 25 Z-Wave devices
  • MySQL installation on Pi (custom DB)
  • Samba installation on Pi (custom)
  • Mosquitto installation on Pi (custom) (MQTT)
    • various devices connected via MQTT

Now I have running in

  • All the above services/devices
  • LetsEncrypt via add-on for https
  • Samba via add-on
  • Mosquitto MQTT via add-on
  • Update setup MariaDB via add-on
    • I put config at the end

I have to say, I was totally expecting it not to work, and I even compensated for this by commenting things out to anticipate this. I don’t think I needed to do this.
I used a separate SD card, so I could roll back without fuss.
Also, I’m ok with losing my DB history for migration

In reality, it worked pretty much out of the box.

I backed up my hassbian configs for:

  • HA (everything in HA dir)
    • configuration.yaml
    • all other .yaml configs
    • zwcfg_*******.xml
  • samba config
    • smb.conf
  • mosquitto config
    • mosquitto.conf
    • pwfile (found in same dir as mosquitto.conf)

Then I installed on a new SD card, didnt bother with wifi (I’ll set that up another time)

Waited for installation to come online and checked IP (Pi has a static IP in my router)

when was online:

  • logged in
  • setup samba add-on via menu
  • deleted default config files via samba
  • copied my yaml config files over via samba
  • copied zwcfg_*******.xml file via samba
  • rebooted via menu

I’m very satisfied so far :+1:


  • installed MariaDB easily via add-on
    • remember to set password with “double-quotes”
    • hit SAVE
    • updated config with:
  db_url: mysql://hass:[email protected]/homeassistant
  purge_days: 14
  • reboot

Does Hassbian have the ability to do backups? I love simply for that reason alone.

I dont think so, I used to do all my backups manually via samba.
It was a pain.

I havent used the config snapshot feature yet myself, but I hear good things. :slight_smile:

As someone that routinely forgot to back up my files (with the AIO installer many times the updates would bork my setup and I’d have to start from the beginning), I routinely do backups now and mirror them on my nas as well.

I was still on hassbian and 0.41, facing some breaking changes and other issues when updating to the latest version, which did not work anymore anyhow. So I tried hassio on a separate raspberry pi 3 and fresh SD card. Took a couple of hours, rebuilding the configuration from the old config piece by piece. I only have an issue with ffmpeg camera that doesn’t work anymore (and I had to fix one python file for my foscam cameras). I did not care about my old database I have to say, so did nor try to port that.

I like the snapshots and the addons (using samba and ssh). I will try let’s encrypt. I’m missing fail2ban and I have to find another place for Avahi print server and PI Hole for now.

So you have spent a couple of hours and downgraded your system. Have you found any advantages?

Well, probably not because of, although indirectly the advantage is that I’m back on the latest version now (I was stuck on 0.41, update was broken, so I had to do an update from scratch anyhow: hassio was pretty fast, most of the time went into rebuilding the configuration, especially Z-wave, not in hassio). And I learned something and feel like a I contributed a bit in beta testing hassio.

But if your set up is working, and you can update when you want, I do not see an advantage in hassio yet. I have yet to explore the let’s encrypt addon, that is something I would like to add but never dared before, so that might be an advantage to come.

Biggest disadvantage however is that my previous setup ran from a USB stick (without SD card, as my PI had already ‘killed’ 3 SD cards) and now with hassio I’m back to SD card. That is really something I would like to get solved…

I’ve been trying hassio for a few weeks now. My experience so far is it is not as reliable as the same setup using the AIO installer. I can’t restart reliability. Automations don’t work as expected. Again basically a reliability issue. I’m getting errors across the board. Some nest, darksky max retries, lots of REST sensor errors fetching data. This seems to happen a lot:

Error doing job: Fatal error on transport TCPTransport (error status in callback)
TimeoutError: [Errno 110] Operation timed out
2017-09-05 00:42:41 ERROR (MainThread) [aiohttp.server] Error handling request

Might switch back to AIO. Like the idea of hassio but it’s not working well for me.

When I last tried I couldn’t install onto a RPi3 with a USB booted SSD. Has this been solved? I’ve fried 2 SDcards - I’m sticking with SSD!

testing for 10 days,

not good… for sure still BETA

Not as reliable as the same setup
Automations don’t work as expected, few times lights switch on in the middle of the night…

restart via ssh not working etc…
updating not working… Update Available 1 hour ago 0.53, …but i have only link for instructions how to update others OS but not …auto update not working for sure
camera not working,
webgui a lot of times not responding quickly… i have to wait or refresh webpage… ( chrome) in IE not working at all…

IFTTT so slow when connecting to
first time connection will took more than 7 seconds… after first request others will go thru fast, but after 10 minutes of inactivity same agen…slow…


Hassio takes a few hours to get the latest HA.
Camera should be fixed in 0.53. Waiting patiently to test it out :slight_smile:

@kevince52 @kikan

I gotta admit, my experience of has been similarly buggy and I’m getting a bit tired of it as the days wear on. My AIO setup was buggy sometimes, but I felt like I had more of a grip of the issues and workarounds. The AIO setup also ran for weeks without intervention.

List of frustrations:

  • I’m restarting at least once a day now (either via ssh or GUI)
  • random slowdowns
  • automations have a 5-10 second delay that was not present before
  • Z-Wave seems to fall asleep randomly (requires reboot to get Z-Wave back)
  • Logs dont show up in ssh (where do I access my dang logs?!)
  • Upgrade process is unknown, and buggy
    • I have no idea how I can upgrade
    • I see no upgrade info in the Settings/Advanced Settings panel at this moment
    • I see others can upgrade quickly, at time of writing this I know 0.53 is out and others are using it
    • when I upgraded to 0.52.1 via GUI, it took a long time with no idea when it would be done
    • no feedback at all during upgrades, i thought mine was dead and decided to leave it alone (just in case) but it was done after ~20 minutes

On the plus-side:

  • I’m loving the add-ons!
  • snapshot functionality is ace
  • the ease of migration to was amazingly easy

Currently I’m running:

  • Host 1.0
  • Supervisor 0.60
  • Home Assistant 0.52.1

I use docker at work, so I’m familiar with it, but ResinOS is completely new to me.

I started a thread here to determine what I could do to go about troubleshooting, but no responses as of a few weeks now.

As @brendanheyu has indicated, it would also be nice to boot from an SSD.
That would solve some slowdown issues for me I suspect.

Otherwise, I’m getting more frustrated each day.

how do you bakcup with hassio?

Chose snapshots:…

On this page create or restore!

Running with no problems.
These add-ons:
Mosquito broker
Maria db
Let’s encrypt