Show all Active Alexa Timers

@stevemann If you give me a couple of days, I can look into making it show up in the user interface. It looks like they’ve added more information to the documentation that I think will help with that.

And, the card is not found:

Wrong indentation. No dash in front of type.

Should look like this … and I guess this is why yaml is a challenge and I should apologies because i didn’t check before saying to copy / paste

If you were using the dashboard raw configuration editor the format shown in the example is correct but in adding it via a manual card you drop the dash in front of type … This is mine as entered into the manual card

type: custom:card-alexa-alarms-timers
entities_alarm:
  - sensor.dining_room_echo_dot_next_alarm
  - sensor.kitchen_echo_next_alarm
  - sensor.living_room_echo_dot_next_alarm
  - sensor.nigel_s_echo_flex_next_alarm
  - sensor.study_echo_dot_next_alarm
entities_timer:
  - sensor.dining_room_echo_dot_next_timer
  - sensor.kitchen_echo_next_timer
  - sensor.living_room_echo_dot_next_timer
  - sensor.nigel_s_echo_flex_next_timer
  - sensor.study_echo_dot_next_timer
remaining_time_bold: true
show_cancel_button: false
hide_card_on_empty: true
show_device_name: true
show_empty_hours: true
show_alarm_name_seconds: true
display_style: table

Thanks, that fixed it.
My alarms are showing but not the timers. I’ll try with a few more of my Alexa units. I think part of my confusion was that this is the first custom card that I can’t add to a panel by name. And the reason I thought the card was missing was because adding it by cut and paste gave me the same error if I had misspelled the card name. As you noted, YAML-challenged.