Shutter Closed position to 100

Hi guys,

I’m new here on the forum.
I’ve been using Home assistant for quite some time now and I’m very happy with it.
There is one thing that is bothering me and I can’t seem to fix it myself.
I have to shutters of which one covers a door. Due to the fact that position ‘0’ means closed, on a system update, HA closes the shutter. This has lead twice to damaging my shutter as the door was still open.
I’ve tried the shutterinvert command and switching the wires but that didn’t do the trick.

In the MQTT device info it does say ‘position_closed’ is 0 and ‘position_open’ is 100.
I’ve tried adding the info to the configuration.yaml but it seemed like it was ignored as this information is already ‘hard-coded’ in the MQTT
Is there a MQTT publish command that allows me to switch those around?

Thanks a lot!

There are some template solutions in this topic:


I did manage to get the template in. It showed up and the down and stop buttons worked but unfortunately the position did not update.
When I tried the template in the developer tools section, it said “position is undefined”.

I feel like I am getting closer but I’m still looking for someone with the holy grail to help me out.