Siemens RDS110 support

@kgeree I am glad you figured it out :slight_smile: … and yes, the Ocp-Apim-Subscription-Key is indeed what you want.

You can find your API key by snooping on the traffic between the RDS App on an iPhone/iPad and the remote ClimatixIC server. The communication is encrypted using HTTPS so unfortunately you cannot just snoop the traffic using a regular network snooper e.g. WireShark or similar. Instead you have to use an interposing proxy server such as Charles Proxy.

For Charles proxy the steps are as follows…

  1. Install Charles on a PC within your (W)LAN, and make sure that the PC has no firewall blocking access to it.
  2. Follow Charles read me instructions to export an SSE Certificate, and install it on your iPad/iPhone.
  3. Follow Charles read me instructions to identify its IP address, and port number for SSE proxying.
  4. In your iPad WiFi settings, select ‘Use Proxy Server’ and enter the IP address and port number above.
  5. Start the recording function in Charles, and enable SSE proxying for the url ‘https://api.climatixic.com
  6. Open the App on your iPad and observe the traffic; look for the ‘Ocp-Apim-Subscription-Key’ header.

EDIT: see this video https://m.youtube.com/watch?v=r7aV39-CKg4

Thank You! I will try it. It is only working iPhone/iPAd or work with Android system too?

@kgeree please revert back if you could get this working at least with openhab…
thanks

with android, you need to use a phone with < Android 7.0 as from that version Root certificate can only be installed by enabling a custom option on the apk - which is only possible for the app’s developers afaik.

Yes, I read it. Thanks a lot a many help. I got my API key :slight_smile:

did you implement it in openhab? do you get state values and you are able to enable/disable the thermostat zones?

I haven’t implemented yet. I will install openhab next few weeks, after that I try it. I would like to following the description below:

Small success here, changes are being published from Openhab to MQTT and MQTT values are read into HA mqtt sensors.
Afaik its currently one-way (read only) but the concept is working, I’d need to dig into it a bit more how to create the proper switch templates, how to update data (switch on/off) etc…
image

I install the OpenHAB and connect my Home Assistant. In the openHAB have some problem, because only few entity working fine, “Occupancy Mode Present”, “Room Humidity”, “Room Temperature”. I can switch on/off the termostat with Occupancy Mode, but I cant change Comfort, Economy, Unoccupied mode. Working everything fine in the Climatixic webpage, I think the Siemens RDS Binding (3.3.0) have some issue.

image

Try the updated version, JAR file in this post: Siemens RDS Bindings - #15 by AndrewFG - Bindings - openHAB Community and description how to use it few posts above.
(or wait for the next official openhab milestone)
Btw how did you integrate the switch entities? via OH REST API?

Yes, I read it the post from the new JAR file, but I didn’t iplement, because I didn’t acces the OpenHAB file system. I runining the OpenHAB in a Docker.
I use it OpenHAB integration with the Home Assistant.


You need to 1) use the OH UI to uninstall the release version of the OH binding, and then 2) download the newer version of the binding JAR file and drop it in usr/share/openhab/addons/

I deleted Docker image, and installed the Linux in the VirtualBox, and install OpenHAB, after that I accessed the file system. I dropped the JAR file the addons directory, and working everything is fine. Thank you for your help.
I have one problem with the Home Assistant entitys, because they aren’t refresing automaticly. I have checked the Entitys in the OpenHAB however, they are automaticly refreshing there.
If I click OpneHAB integration => system settings => refresh in the Home Assistant, they start refreshing, but after that it doesen’t work again. Could you please help me solve this problem?

1 Like

I am not an expert on MQTT … but it probably depends on whether the MQTT server on OH is set to push on change, and/or whether the MQTT client on HA is set to pull by polling.

I made a workaround. I restart the integration every 5 minute. :slight_smile: It is working.

automations.yaml

  trigger:
    - platform: time_pattern
        # You can also match on interval. This will match every 5 minutes
      minutes: "/5"
  action: 
    - service: homeassistant.reload_config_entry
      data:
        device_id: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
1 Like

are you using it via MQTT? did you set the “Profile” of the linked MQTT channels to “Follow” (Követés)?

with that its working fine for me, however for switch integrations I’m now using the REST api of Openhab, which seemingly working fine so far…

I try to set “follow” in the “Profile”, but nothing change. The values in the Home Assistant are not change. I thing is the problem Home Assistant integration (know issues #22).