Simpleicons for Dummies

I used HACS to install simpleicons. Everything seems ‘successful’: the integration shows up in the HACS section; and there is a new subfolder in custom_components on my Raspi called “simpleicons.” But if I select say, si:amazon all I see is a blank icon.

  • I’ve tried installing the latest beta (v2.00-RC1).

  • I’ve tried viewing in three different browsers: Chrome, MS Edge, and Firefox. I’ve deleted the stored data (cookies, cache, etc.) in the browsers and restarted them.

  • I’ve deleted and reinstalled the integration several times, always with a reboot in between steps.

  • I’ve gone to the simpleicons screen and selected the icons I want. When I click on an icon, I get a pretty check mark. I can also download that icon.

  • I even copied the downloaded SVG files to my custom_components/simpleicons/data folder.

I’ve tried several different icons: Facebook (si:facebook), Amazon (si:amazon), Roku (si:roku), etc. but all of them result in blank icons. What am I doing wrong? Can anyone provide simple steps for a five-year-old, to help out this 66-year-old former software engineer? :face_with_raised_eyebrow:

Patton (tanks in advance),

1 Like

I’m having the same issue. Installed via HACS, restarted and all icons are blank.

I overwrote the existing files with the v2 RC version, restarted again and now it’s working. I had to refresh the page to see the icons, but they’re now there!

@Duncan Re: Thanks. I’m pretty sure that I already tried those exact steps, but I’ll try it again today. Maybe there’s a newer RC than the one I tried?

@All: On a related note, is there a ‘proper’ place to put things like icon archives for HA, other than to open a GitHub page? I took hulkhaugen’s hass-bha-icons and massage it (them?) into an archive of icons I use as a musician with things like:

  • subwoofer
  • rack cabinet on wheels
  • lighting tree
  • PA speaker (plus left and right versions)

And since I was having issues with SimpleIcons – and the archive doesn’t have some of the stocks I use in my finance tracker – I created another archive with logos for:

  • Intuitive Surgical
  • Roku (a square icon that looks better, IMO)
  • Asus (same)
  • Fidelity Investments
  • Dow Jones
  • etc.

I’d be more than happy to share these with the community. Once I discovered the ‘formula’ for adding icons to a library, it only takes me a few minutes per item, if the icon is already monochrome. But, technically, I didn’t ‘create’ an integration; I just hacked someone else’s efforts.



@DuncThePunk I tried installing v2-RC1 again: same results. I’m sure that I’m doing something wrong, but I don’t know what. So, it’s back to the archive I made.

clear your cache & viola!