Since update to HA Core 22.5.0 cannot switch off Ikea Tradfri sockets

I have a number of zigbee devices working with a Conbee II Zigbee hub, including Tradfri bulbs, Tradfri sockets and an Osram bulb. They have all been working fine with automations, scenes, dashboards, etc.

However since the upgrade to HA 22.5.0 and continuing with 22.5.1 there is a strange behaviour: All my automations and scenes are continuing to run, except for switching off a Tradfri socket using a scene.

I tried creating a new scene which had a single Tradfri socket set to ‘off’ and the behaviour was the same as with existing, more complex scenes: the scene will not switch off the socket.

Is this the right place to be asking this, or do I need to create a bug report in Github (I’ve never tried to do that before).



I’ve also noticed since the update that my Tradfri switches don’t work when i hold them anymore. Single presses work fine still.

This might be related to this one

It was not listed under breaking changes for Home Assistant core but if you are using any Blueprints then each blueprint may have to be fixed and updated due to changes in ZHA and its dependencies.

Because root of such bugs are in the blueprint no breaking changes was listed for Home Assistant core.

See example:

PS: Since blueprints are not automatically updated you need to manually update after fixes are merged.

Are you sure this is related to just the blueprints?

Because my HVAC heating via eurotronic devices also do not work anymore. Not with the blueprints and the automations and even not in the GUI or via developer tools.

So something must have been changed.

Some things have changed for attributes of ZHA devices that can affect blueprints and automations that uses ZHA events, more info in

FYI, those curious can other than Home Assistant core issue #69375 also track ongoing work here:



Most of the open and merged pull requests there from the 6th of April 2022 and on are related to this.

Is this fixed for you gents?

Tried it with the update to 2022.06.1, but it still does not work :frowning: