Since upgrading to version v.77 I can not long login over 3 g

my address work on internal lan but using 3g on phone it hangs at loading…

Tried new auth
tried legacy
tried two factor

what am I doing wrong? Nat is in place on firewall to correct internal ip

You should probably remove your actual address, and your issue is likely browser cache. Have you read about the new authentication?

And you’re running it over normal HTTP? No HTTPS? You might want to just pull remote access off of it entirely right now.


So without https your saying do not use remote access because it broken?

No, I’m saying that your password is being broadcast to anyone that is able to sniff that traffic. You have no encryption and no security.

hahaha I am not cared about that the best they can do is switch on/off my lights

Read about new auth but still confused I thought using old legacy it would work but does appear too.

Legacy API should still work, it works on mine.

If it’s stuck on Loading Data, you probably need to clear your browser cache and reload the page. Also delete the auth files from your config and try to register again.

tried from a brand new PC never ever connect been connected to HA and 3g fails internal works?

From iPhone safari cleared cache still no joy.

Also delete the auth files from your config and try to register again??? tried that no joy. Also works on internal LAN??

Hold on. What version are you on? There were a bunch of fixes for authentication in .77.3 78.2 was just released an hour or so ago.

Try updating.

tried almost all the versions. currently on 0.78.2

Did you set up cors or base_url?

By the way, we denied all access from external network using public IP address, you must have your domain name configured.

1 Like

No cors or base url setup

And yes from safari web browser = no

Did I need to hard code the domaim name into HA

You need setup base url

1 Like

added this to configuration.yaml

  api_password: whatever

but no joy? What am I doing wrong.

Add cors_allowed_origins as well

what does cors allowed do? sorry I am confused?


but what URL do I need to add?

Anyone know what is needed for CORS? do I just add the website that my config reference such as MDI icons, etc?

BTW I still can not access the web site over 3G