Sinope Line Voltage Thermostats

I see, I think we need to create sensor specific for energy usage attribute of the device and add that sensor into the energy dashboard. I’ll try to add sensor creation directly in the custom_components. This is my next improvement for my custom_components. Meanwhile just create the sensor you need and add them to the energy.

That’s a good way easier then tracking ieee

That would be amazing if you could do that… It would be really nice just to see that data in the native energy monitoring in HA.

I’m not exactly a wiz when it comes to coding, most of the devices in my home have nice ui based implementations but I’m getting some error/warning messages from the sinope setup, so maybe I missed a step somewhere?

For context, I’m running on HAOS, Raspberry Pi 4b, freshly created from pi imager yesterday.

First there’s this warning: HomeAssistantType was used from sinope, this is a deprecated alias which will be removed in HA Core 2025.5. Use homeassistant.core.HomeAssistant instead, please report it to the author of the ‘sinope’ custom integration.

Then this error: Logger: homeassistant.components.climate
Source: helpers/entity_platform.py:356
integration: Climate (documentation, issues)
First occurred: 4:40:29 PM (1 occurrences)
Last logged: 4:40:29 PM

Error while setting up sinope platform for climate

Traceback (most recent call last): File “/usr/src/homeassistant/homeassistant/helpers/entity_platform.py”, line 356, in _async_setup_platform await asyncio.shield(awaitable) File “/config/custom_components/sinope/climate.py”, line 204, in async_setup_platform dev_list.append(json.loads(line)) ^^^^^^^^^^^^^^^^ File “/usr/local/lib/python3.12/json/init.py”, line 346, in loads return _default_decoder.decode(s) ^^^^^^^^^^^^^^^^^^^^^^^^^^ File “/usr/local/lib/python3.12/json/decoder.py”, line 337, in decode obj, end = self.raw_decode(s, idx=_w(s, 0).end()) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File “/usr/local/lib/python3.12/json/decoder.py”, line 355, in raw_decode raise JSONDecodeError(“Expecting value”, s, err.value) from None json.decoder.JSONDecodeError: Expecting value: line 2 column 1 (char 1)

I get the same error for switch and light but I only have line voltage thermostats connected through a GT125.

Edit: Something must have gone sideways in the sinope_devices.json file because renaming and recreating it looked the same to me but works now.

So, aside from a “taking longer than 10 seconds to start” warning, is there any indication that the devices are actually enabled? I kind of expected there to be devices or an integration icon added to the graphics. Is it only accessible though coding?

Hi @LoganFraser, first the message about HomeAssistantType won’t prevent the sinope GT125 to load the devices. I’m working to fix this soon. HA is doing a lot of code cleanup and they deprecate many thing that we need to change but we still have until 2025 to fix it.
The other message about line 204, in async_setup_platform is because your file sinope_device.json was wrong. You should use device.py to create that file. You can edit it to change the device names but you must be carefull not to break it.
Finally to see if your devece is loaded just look in dev tools / state to find your device like climate.sinope_climate_… If it is loaded you will see values as temperature etc If it is not you will see unavailable.
I’m gona push a new release this weekend to fix those messages about HomeAssistantType.

Yep, got that part working. Is there a way to have it appear on the integration or devices list? I had to manually add the sinope to Hubitat as well but it showed up as devices with temperate settings in the GUI.

Just edit the dashboard and add a thermostat card. in the card add your device and it will showup

1 Like