Sinope Line Voltage Thermostats

(post deleted by author)

template:
    -  sensor:
         - name: "Den_energy_sensor"
           unique_id: sensor.den_energy_sensor
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb130_climate_Den','hourly_kwh_count') }}"

Then go to developer tools, states and look for your sensor.den_energy_sensor
There should be a value in the second column. If that work this is the name you need to import in the energy dashboard.

The state attribute looks wrong. Change it to your device.

@jdawson
Just replace the capital letter in your device name and sensor name like this
Den → den

state: “{{ state_attr(‘climate.neviweb130_climate_den’,‘hourly_kwh_count’) }}”

Make sure climate.neviweb130_climate_den exist in the developer tool / states

Then check in developer tool / states for the name of your sensor:

sensor.den_energy_sensor should exist and have a value in the state column.
If this is ok then your new sensor can be added in the energy dashboard.

1 Like

could it be possible his state attribute for hourly is below?
state: “{{ state_attr(‘climate.neviweb130_climate_den’,‘hourly_kwh’) }}”

Both exist:
hourly_kwh is number of kwh consumed in one hour
hourly_kwh_count is summation for the first one, updated every hour
@jdawson must validate the proper name of his thermostat and sensor in developer tool and if possible post a screen capture so we can validate. Normally HA replace allcapital letter with lowercase letter. Alle attributes names must also be lowercase.

IC. thank you for clarifying.
There is another way to create a sensor as well. I use the UI helper which is quite easy to do now compare to a year ago.

Ok found it with your printscreen
You’re with a miwi device in the neviweb custom_component. For those device there is only two energy attributes:
hourly_kwh
daily_kwh


So you need to change your sensor for:

template:
    -  sensor:
         - name: "den_energy_sensor"
           unique_id: sensor.den_energy_sensor
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total
           state: "{{ state_attr('climate.neviweb_climate_den','hourly_kwh') }}"

This should work

Your device name is climate.neviweb_climate_den
It’s not climate.neviweb130_climate_den
You must always validate in developer tool/states for the correct name of your device et the name of your device attribute that you can use.

It is not necessary to repeat -sensor : for everyone, just once is enough.


template:
  - sensor:
      - name: "Énergie quotidienne chauffage salle familiale"
        unique_id: "energie_quotidienne_chauffage_salle_familiale"
        state: "{{ state_attr('climate.neviweb130_climate_salle_familiale', 'daily_kwh') }}"
        unit_of_measurement: kWh
        device_class: energy
        state_class: total_increasing

      - name: "Énergie quotidienne chauffage atelier"
        unique_id: "energie_quotidienne_chauffage_atelier"
        state: "{{ state_attr('climate.neviweb130_climate_atelier', 'daily_kwh') }}"
        unit_of_measurement: kWh
        device_class: energy
        state_class: total_increasing

      - name: "Énergie quotidienne chauffage chambre invites"
        unique_id: "energie_quotidienne_chauffage_chambre_invites"
        state: "{{ state_attr('climate.neviweb130_climate_ch_invites', 'daily_kwh') }}"
        unit_of_measurement: kWh
        device_class: energy
        state_class: total_increasing

(post deleted by author)

I use the sensors in the Individual Device section.

Ok I did that thanks…

The variable we are using hourly_kwh goes back to 0 every hour.

I noticed your using total increasing in class should I use that? Or should I also use the daily_kwh variable using total increasing?

Right now i see NO data… but part of the problem is I know I have no heat on because it is summer… But even when i turn on something for a few min so it shows in the graph in the neviweb app i have never seen it show in the HA data yet.

(post deleted by author)

Ok everything is working now with this configuration for me…

Thanks to @ValMarDav and @claudegel for all your assistance.

template:
  -  sensor:
         - name: "bathroom_energy_sen"
           unique_id: sensor.bathroom_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_bathroom','hourly_kwh') }}"

  -  sensor:
         - name: "bedroom_energy_sen"
           unique_id: sensor.bedroom_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_bedroom','hourly_kwh') }}"

  -  sensor:
         - name: "den_energy_sen"
           unique_id: sensor.den_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_den','hourly_kwh') }}"

  -  sensor:
         - name: "dining_room_energy_sen"
           unique_id: sensor.dining_room_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_dining_room','hourly_kwh') }}"

  -  sensor:
         - name: "ensuite_energy_sen"
           unique_id: sensor.ensuite_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_ensuite','hourly_kwh') }}"

  -  sensor:
         - name: "hall_energy_sen"
           unique_id: sensor.hall_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_hall','hourly_kwh') }}"

  -  sensor:
         - name: "joe_office_energy_sen"
           unique_id: sensor.joe_office_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_joe_office','hourly_kwh') }}"

  -  sensor:
         - name: "karen_office_energy_sen"
           unique_id: sensor.karen_office_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_karen_office','hourly_kwh') }}"

  -  sensor:
         - name: "living_room_energy_sen"
           unique_id: sensor.living_room_energy_sen
           unit_of_measurement: "kWh"
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_living_room','hourly_kwh') }}"

  -  sensor:
         - name: "porch_energy_sen"
           unique_id: sensor.porch_energy_sen
           unit_of_measurement: "kWh" 
           device_class: energy
           state_class: total_increasing
           state: "{{ state_attr('climate.neviweb_climate_porch','hourly_kwh') }}"