Skoda connect: cannot login!

Hi, I installed the Skoda Pugin and I cannot even login.
I have the latest HA-OS installed on a Proxmox install on a laptop. In not sure where I can see the current version, but I always keep it up to date.

The error I see in the log:

This error originated from a custom integration.

Logger: skodaconnect.connection
Source: custom_components/skodaconnect/
Integration: Skoda Connect (documentation, issues)
Missing consent for client "technical" scopes: profile

I installed from an android phone, running the Skoda app, and at the same time I was logged in with Chrome browser, with the same credentials.
First from HACS, then (several) restart(s) of HAOS and then add integration from the devices menu.

There is just one thing: I don’t have my owners- data yet. Will get that on Monday. So there is one thing, not sure how it’s called, that is not verified in the Skoda app yet. But I can see all data in the app. Is this the reason for my problem?

What can I do to solve this?

In the meantime my car in Skodaconnect has been confirmed. But unfortunately I still can’t login with error message: ‘Could not login’.
The log says:

Login failed with error: Missing consent for client “technical” scopes: profile.

The Skoda app and the Web interface are working fine on the same device.

I found the solution on github: “Just login on the “old” application “MySkoda essentials”, not the new “MySkoda”, and then it will work in HA!”

Worked for me!


Thank’s, it has already worked for me :wink: