SkyConnect: bunch of settings missing from entity (works fine through zigbee2mqtt)

Hi everybody,

I have been using zigbee2mqtt for years, and am now slowly switching devices over to SkyConnect. I recently bought three Xiaomi SRTS-A01. One is connected to zigbee2mqtt. Below are screenshots of everything, let me explain first.

The two thermostats I connected via SkyConnect only allow me to set temperature and HVAC Mode (heat, cool, heat/cool, off). The thermostat connect via zigbee2mqtt also allows me to (de)activate window detection, valve detection, child lock, and more. It seems like this is not possible via SkyConnect - but hopefully it actually is, and I just missed it…

I was hoping to completely switch to SkyConnect (one less service running on it’s own), but these features, especially windows detection, are essential to me. I have window sensors and Home Assistant automations doing this, so I don’t want/need the thermostat itself to determine the window status.

Thank you in advance for your help :slight_smile:


device connected through zigbee2mqtt (auto-discovered by Home Assistant)

devices connected through SkyConnect (both the same, only providing screenshots for one of the two)

Hi @prankousky
I was just about to post similar problem although I’m using Sonoff Zigbee 3.0 USB Dongle Plus.
My Tuya Airbox under Zigbee2MQTT gives me Co2, Humidity, Temperature, Formaldehyde and VOC entities where under ZHA I got VOC entity only.

All I did to fix this problem was switching the name of the USB Device Filter from
ITead Sonoff Zigbee 3.0 USB Dongle Plus [0100]
Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light [0100]

I can.t explain the logic behind that because I’m newbie and solved it by luck but maybe it can lead you to resolve the problem at your end as well.
And I’m interested what others will have to say about that. From what I remember other parameters of the filter impact your dongle as well even using Zigbee2MQTT.

1 Like

Thank you. This sounds like an interesting approach. However, I run Home Assistant in a docker container inside a proxmox vm. The USB device was automatically discovered by Home Assistant after I mounted it through the Proxmox UI.

I cannot seem to change anything about the stick in the Proxmox UI or via docker.

Hopefully this will be fixed without having to change/switch anything in the future. I just ordered an additional SkyConnect dongle for my parents’ house, as I thought it’d be easier (and I wouldn’t have to do that much tech support then :wink: ) but it seems like z2m would be a simpler way to go at the moment.

1 Like

Take a look here It says go with ZHA if all devices works fine as it is very simple setup. I use a lot sensors and plugs, they are all good. Only Smart water valve doesn’t show me water flow volume, I’m getting binary off/on only, so I will be looking into it as well.