SkyConnect Dongle Repair

I just got my Home Assistant and SkyConnect Zigbee dongle yesterday. Set everything up and now i have an error on the skyconnect. Says there is a repair created but nothing shows up, no link nothing. I have tried disabling and reenabling it but then it will say i dont have the firmware for it. I try to go through a fresh installation and it won’t finish the installation after getting stuck at it saying i dont have the firmware. I’m stuck and dont know where to go. I have zigbee devices that i had hooked through Smartthings and bought the Skyconnect dongle to be able hook zigbee devices directly into HA. For now i have Smarthings synced to HA to show the zigbee devices but i want them directly in HA. Can someone help?

Can you manually flash the newest firmware to your stick?
As described here: Matter & Thread: where we’re at - Home Assistant and Home Assistant SkyConnect
Use google chrome. If it is not working, use another usb port or another pc.

A successful firmware installation using this method would indicate a functioning Skyconnect stick.

I’ve never tried flashing anything but I’ll give it a shot.

Highly recommend that flash it with Zigbee (NCP) firmware to make it a dedicated Zigbee Coordinator:

Click “UPDATE FIRMWARE” → “CHANGE FIRMWARE” in SL Web Tools then choose “Zigbee (EZSP)”:


You will then also need to disable multiprotocol support in Home Assistant:

Note that it is no longer recommended to use RCP Multi-PAN (multiprotocol) firmware:

Note! If also want to use Thread then recommended buy another separate SkyConnect and flash that with the “OpenThread” firmware to make it a dedicated OpenThread Board Router for Thread-only:

There is a third, experimental, firmware option that supports multiprotocol, which allows the Silicon Labs chip in these products to connect to both Zigbee and Thread networks with one radio. We announced our intent to release a firmware supporting multiprotocol when we launched Home Assistant Yellow and Home Assistant SkyConnect, and this firmware has been available since December 2022. It integrates the Silicon Labs SDK, which adds this support for multiprotocol. During the further development and testing of the multiprotocol firmware, we have concluded that while Silicon Labs’ multiprotocol works, it comes with technical limitations. These limitations mean users will not have the best experience compared to using dedicated Zigbee and Thread radios. That is why we do not recommend using this firmware, and it will remain an experimental feature of Home Assistant Yellow and Home Assistant SkyConnect. If you currently have the multiprotocol firmware installed but don’t actively use it to connect to Thread devices, we recommend that you disable multiprotocol.

PS: More detailed explanation on why should use separate radio adapters for each protocol found here:

You’ll have to forgive my stupidity but when I plug the SkyConnect into the USB drive of a computer it doesn’t recognize the device at all. Should the HA Green and the SkyConnect dongle be plugged into the same computer? Only issue is the only desktop I have is in another room because I only have one live ethernet jack in the house and it’s plugged into the router. (stupid ISP)

If using Windows or Mac OS then you first need to install Silicon Labs CP210x USB to UART Bridge VCP Drivers for the USB-to-serial converter chip used on the SkyConnect → CP210x USB to UART Bridge VCP Drivers - Silicon Labs (this only comes preinstalled on some Linux OS distros).

SkyConnect dongle firmware can be flashed with the SL Web Tools webpage on any computer with internet that you plug it into, that is, the SkyConnect only need to be plugged into the computer running Home Assistent when you are actually using its radio.

Thanks everyone, looks like it is working just fine now (hopefully). I disabled multiprotocol and skyconnect/zha and then flashed with the labs. Actually started the flash a second time to make sure (as it didn’t say it was actually done). After doing that, went back to Devices screen and there it was a discovered device. Went through and configured like it was a new device and started a new network instead of migrating, so started it over by scratch. Tested it by connecting a Zigbee Bulb and it connected/interviewed and then went on and connected 4 more zigbee bulbs. Thanks everyone!!!