Skyconnect - Hama 00176592 Smart Radiator Thermostat not turning on or changing temperature [ZHA]

I bought myself the Skyconnect stick to use zigbee. I want to integrate following thermostat in ZHA: Hama 00176592 Smart Radiator Thermostat =>
Connecting the thermostat to the Zigbee network was straight forward. I had no issues there.

What I am struggling with, is that I cannot change the temperature on the thermostat. It responds almost instantly, when I manually change the temperature on thermostat. When I try to change the mode to heating, it just waits a little bit and then nothing happens.
I am a little lost because I have read so much about custom quirks and it all seems a little complicated.
Is there any way I can fix this?
Cheers and thanks for your help! :slight_smile:

Hello i have the same problem, you have fix it?

I switched the devices over to zigbee2mqtt. There the thermostats worked instanly and without any issues so far!

i bought the same thermostate hoss Amazon. Useing zigbee2mqtt (with a Sonoff stick) i am not able to discover det devices and get them to join my zigbee network.

I just tried to power up them and use “anlernen aktiviert” in Zigbee2mqtt. Is their something else that i can do or have anyone an idear why it is not working?

i just have found a solution: The device will not pair in the orginal “inition mode”. You have to wait till “LO” is turned out, turn the heating temprature to “off” and press long on the top bottom. Then it will enter a paring mode and i was able to add it to Zigbee2mqtt just buy useing “allow new devices to join”.

Does it work flawlessly now with skyconnect, with all its functions?