SkyConnect marking devices as unavailable

Hello everyone!

I pre-ordered a SkyConnect, and I wanted to replace my ConBee II + DeConz setup as it didn’t really work with many devices, Z2M is a bit too much for my setup, and I thought that SkyConnect + ZHA might do the trick, but things didn’t go as planned.

My setup is composed of a Raspberry Pi 4 running, and I plugged the SkyConnect to the extension cable to one of the USB 2 ports of my setup. The issue is that the SkyConnect would often not pair devices that I previously paired with DeConz (I followed up the guide here, I reseted them, I even tried on a blank new instance of Home Assistant) and when I finally could pair them, they would quickly become unavailable and never get back online, unless I repaired them. At that point, they would become unavailable once again. I updated SkyConnect firmware, no luck there either.

I did some tests, and migrated the whole setup to ConBee II with ZHA, everything was working almost fully. I did a third attempt, switching to the SONOFF Dongle, and everything is working fine.

I found several posts about SkyConnect misbehaving in certain ways, and I tried all the solutions posted in them, but at this point I think mine might be faulty. What would you think? Should I ask for a replacement?

And you’ve tried the usual USB extension cables, plugging into USB2 ports etc ?

If so, you might just be on the list of people that are reporting compatibility issues with the skyconnect.
I believe there is a zigbee only firmware you can flash onto it, pretty sure if you dig around the forums you’ll find links to that, but no guarantee it will fix your issue.

Hello! Yes, I actually tested 3 different cables, with the same result. I tried both the Matter-ready and the Zigbee only firmware, same result, unfortunately. And I’m a bit sad about it :frowning: is it possible there was a first batch that was faulty? :thinking:

1 Like

I am wondering the same

Probably interference, read →

@Hedda thanks for the link, but I’m wondering why both the Sonoff working fine and the ConBee are working fine in the same position, and the SkyConnect is not… wouldn’t they be affected by interference as well?