SkyConnect - No Thread Border Router


Have the skyconnect installed and functioning. At one point the thread border router was in the add ons section. However this morning it was in a failed state. I went ahead and removed it, then attempted to re add it however getting this request: Provide URL for the Open Thread Border Router’s REST API

I tried http://localhost:8081 and 8080 which is normally what thread operates on but Its not working. How do I get this OTBR back in the add ons and connected. I thought it was part of the Sky Connect install


I just got my SkyConnect and was having the same problem. I had to go to my Hardware settings in HA and turn on “Multiprotocol support” and once that finished setting up my Skyconnect was found as a Thread Border Router. Hope this helps. :slight_smile:

1 Like

I have the same…

@iGageit that does not help, mine and I think @abianucci’s was already set to Multiprotocol support

That happened to me as well. When I restarted my machine the OTBR showed back up in integrations. I hope this helps.

1 Like

I just dit the same, and mine came back to! but… when my VM was powered down I also noticed that my SkyConnect was not listed in the USB devices of that VM anymore. It was and I still got updates for it. Maybe some ID changed in a update that got me (us?) in this situation?

Anyway, It’s fixed now…

So, question for anyone in this thread? Has enabling multiprotocol support caused any change in behavior on your Zigbee network?

I upgraded several weeks ago from a Conbee II stick (that was rock solid) to SkyConnect and it was very challenging. Things are just now starting to settle down and I had to replace a few switches that simply wouldn’t cooperate.

Sooooooo… while I really want to enable multiprotocol support and start learning about it (no, I don’t have any devices yet except maybe my Echo gen 5), I DON’T want to enable it if my Zigbee network is going to start misbehaving again.

Any insights greatly appreciated!

I don’t have any Zigbee, sorry.

I have the same problem here. I’ve enabled multiprotocol support. At Settings > Devices & Services i can see Thread, but when I click çonfigure’, it says I have to set the URL for the Open Thread Border Router REST API. I’ve tried http://localhost:8080 and 8081 at no result.

What can be wrong?

In Add-ons > Silicon Labs Multiprotocol > Configuration I’ve changed the Baudrate. After trying several baudrates, I now have THREE OTBR’s, even after restarting HA.

Now that cannot be correct, since I only have one device. How do I get rid of the extra ones?

BTW, the highest baudrate that seems to work is 921600 baud. Setting this might help others?

Solved: setting it back to default settings there solved it. I now have only one instance.

Can you be more specific? What did you set back to default settings? I assume what was fixed was the multiple OTBRs, but could you confirm that?

Since a couple of weeks I’m facing the (same?) issue. OTBR (with Multiprotocol enabled) was working fine until some 3-4 weeks ago it would suddenly not initialize anymore and be in a failed state. Also the HomeKit sensor connected via Thread would not work anymore. At the same time, the Zigbee-network still works fine. I’ve tried deleting the OTBR integration as suggested above but now I cannot add it anymore as it keeps me asking for the REST API URL and neither port 8080, 8081 nor 9999 work with localhost.

I was finally able to get it resolved in my case:

  • Make sure all of the below integrations are removed
    • Open Thread Border Router
    • Thread
    • all HomeKit devices previously configured via Thread
  • Reboot the system (rebooting Home Assistant is not enough)
  • After the reboot the Open Thread Border Router and Thread integrations re-appeared automatically
  • After that and factory-resetting the devices previusly connected via Thread, they automatically reappeared as HomeKit devices in the discovered integrations section.

Now, I don’t know if this was pure luck or coincidence and if this will work for anyone else. But just thought to share it here in case it helps.


To re-add OTBR (after manual deletion) in the integration’s list I had to disable the OTBR firewall in the Silicon Labs Multiprotocol configuration, because I see these errors there otherwise:

[03:25:55] INFO: otbr-agent ended with exit code 1 (signal 0)...
[03:25:55] INFO: OTBR firewall teardown completed.
[03:25:58] INFO: Setup OTBR firewall...
ipset v7.10: Kernel error received: Invalid argument