Skyconnect not work

I have now connected the skyconnect to my PI4. Unfortunately, I can’t add devices through zha. The skyconnect plug is recognized perfectly in the system and zha is also installed without errors.
However, no device can be added to the Zigbee network because no device (e.g. OSRAM Plug or Aqara devices) can be found. I’ve already used a longer USB cable (about 3m) to avoid interference. No success. I also don’t get any log output in zha.
How can I check my installation or how can I get the skyconnect to work.

I have the exact same problem. I purchased a SkyConnect and finally received it last week. I have since wasted days of effort trying to get the thing to work. When I add it to HA/ZHA on my RPI-4 everything installs normally. However, once installed, it never sees any device I try to add. I’ve tried Sonoff and Aqara devices so far.

Here is my configuration…

Home Assistant 2023.3.3
Supervisor 2023.03.1
Operating System 9.5
Frontend 20230309.0 - latest

This is really frustrating and I really hope someone can let me know if I have a defective SkyConnect or if this is a known issue.


Did you already try going flashing the latest version of the Zigbee only firmware?

Where does one find the firmware for this device?


Home Assistant SkyConnect And GitHub - NabuCasa/silabs-firmware: Silicon Labs firmware for Yellow and SkyConnect

Thank you for the reply and links Frank. I read through the pages and I’m not sure changing the firmware is a good next step for me in troubleshooting. I purchased this device because it was suppose to be plug and play. I can’t just keep making changes when I have no clue what the problem is. As I said, the device installs just as it is suppose to but never hears another device. There has to be some sort of troubleshooting I can do besides arbitrarily changing things. Should I try someone else’s dongle? $30 for another brand dongle beats wasting hours and days spinning my wheels.


I’ve heard several people talking about issues with SkyConnect, and if you’ve already tried the extension cable, you might well be better off flashing it (for now). I think the process is fairly straight forward.

Okay, I updated the firmware in the SkyConnect from 7.1.1 to 7.1.4. The update was uneventful and after loading it, the device remains completely unresponsive when attempting to pair new devices.

When I attempt to pair any zigbee device I get nothing in the logs on the add device page. Is there any way to tell if I got a defective SkyConnect?

I need to be able to do logical troubleshooting but at this point all I can still say is the SkyConnect is discovered and installed normally. HA is happy with the install. However with multiple devices I have never gotten anything to be discovered or make an entry in the logs.


I have similar issues.
I bought SkyConnect mainly to get Zigbee as I bought 20 Aqara Zigbee window and door sensors.
My SkyConnect is connected to my HA Raspberry Pi4 with a 3m extension cable.
HA picked up SkyConnect immediately but adding devices has been very difficult. Even standing next to the SkyConnect dongle. However - I have somehow gotten 3 devices connected and they are visible in HA. None of these devices were paired on the first or second attempt but once they were paired they work very reliable (connection wise) and the response time is very quick.

Just plugged my SkyConnect into pi4 using the extension cable.
Then clicked on settings, got an error and…
Rebooted. Nothing.
Unplugged, rebooted. Nothing.

Ok, stand down.
My case was simple bafoonery.
My cat 5 cable, missing its clip…slid out just enough.
Tragedy averted.

I have been searching and trying for weeks to get Skyconnect working. I don’t know what happened when it was new, it worked for about three days and then nothing.

It must have been a useless purchase :sleepy: :sleepy:

I am too starting to have issues. Every now and then the Skyconnect stick becomes unresponsive. Restarting Homeassistant or rebooting the server doesn’t solve the problem. Only thing that helps is unplugging the stick and putting it back in. Error I am getting is:

Logger: homeassistant.config_entries
Source: components/zha/core/ 
First occurred: 05:55:40 (1 occurrences) 
Last logged: 05:55:40

Error setting up entry SkyConnect v1.0 for zha
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 383, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/zha/", line 122, in async_setup_entry
    await zha_gateway.async_initialize()
  File "/usr/src/homeassistant/homeassistant/components/zha/core/", line 185, in async_initialize
    self.application_controller = await
  File "/usr/local/lib/python3.10/site-packages/zigpy/", line 171, in new
    await app.startup(auto_form=auto_form)
  File "/usr/local/lib/python3.10/site-packages/zigpy/", line 145, in startup
    await self.connect()
  File "/usr/local/lib/python3.10/site-packages/bellows/zigbee/", line 124, in connect
    self._ezsp = await bellows.ezsp.EZSP.initialize(self.config)
  File "/usr/local/lib/python3.10/site-packages/bellows/ezsp/", line 105, in initialize
    await ezsp._startup_reset()
  File "/usr/local/lib/python3.10/site-packages/bellows/ezsp/", line 96, in _startup_reset
    await self.reset()
  File "/usr/local/lib/python3.10/site-packages/bellows/ezsp/", line 125, in reset
    await self._gw.reset()

Read and follow all this here →

As well as those here →

Same issue here.
New dongle, perfect installation process with zha, no devices seen…

Exact same issue here!

  • skyconnect with its usb cable
  • raspberry pi 4
  • I’m using the usb 2.0 port

I’ve successfully installed skyconnect + zha integration.

I can’t add any zigbee devices (I’ve tried with Aqara devices and sonoff devices, including new devices I’ve just bought).

Up to now I can’t do nothing.

Is Nabu casa aware that so many people are experiencing issues with skyconnect?

Thank you


Other than using USB 2.0 and the extension cable have you taken other recommended actions to avoid interference? → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Enable debug logging and open an issue with debug logs to the Home Assistant core repository →

1 Like

Thank you very much for your kind answer! I’ll make some more attempts in the next days, and I’ll write in this tread.
I haven’t tried yet to completely shut down my raspberry, rather that restarting it…
I’ll let you know!

I struggled with this issue for an extended period, and as others in the community suggested, temporarily disconnecting the device from USB and then reconnecting it did resolve the problem each time, but it proved to be an exasperating workaround. Eventually, I discovered that uninstalling cyliconexxxx in the device manager ( in the port sections) and then reinstalling the hardware consistently resolved the issue. The only drawback was that in the event of a PC reset, I had to manually perform these steps.

Eventually, I created PowerShell commands and integrated them into the Windows Task Scheduler to automatically uninstall and reinstall the device right after a system reset. This streamlined approach finally put an end to the problem.