Skyconnect not working... at all

I am using Home Assistant OS on a Raspberry Pi 4.

The SkyConnect I ordered doesn’t seem to work at all. I think I may have been sent a defective product. I have it attached to the provided extension cable about 8 inches away from any USB ports or other electronic devices. I have also tried a longer extension cable moving it several feet from any other electronic devices. I tried it on both a USB 2.0 port and a USB 3.0 port.

It DOES show up under Hardware > All Hardware, but it does NOT get automatically recognized under Integrations.

It also does NOT connect when I try to set up the ZHA integration manually. It always just gives an error like “unable to connect”

I was also having connection issues when trying to set it up on Zigbee2MQTT. I am currently running Zigbee2MQTT on another dongle and that is working perfectly.

I tried updating the firmware on the SkyConnect, but it didn’t have the required driver on my MacBook and the stick wasn’t even detected on Windows. When I try to install the driver, it says I’m not allowed to access the driver download. So, I wasn’t able to do that either.

1 Like
  • Maybe post what it is actually showing in Hardware->All Hardware
  • Are you using or have you ever used the SiLabs Multiprotocol Add-ON?

Shows in Hardware

SL Multiprotocol Add-On installed and running, but has no logs

No border routers found

No integration automatically detected for ZHA either



Everything looks fine as far as I can tell, so we somehow need to get a look at why Multiprotocol AddOn is crashing. Try Settings->Systems->Logs in the upper right corner there is a pulldown/select SILICON LABS MULTIPROTOCOL. See if it shows anything.

I also tried uninstalling and reinstalling the addon and get the same results. And the add-on crashed, but no logs are available due to an error.

That’s a tough one :frowning: . The only other suggestions I have, is if you can get access to the HassOS linux shell, run journalctl (which may output a lot of log entries of everything) and see if there is anything there for the silabs multiprotocol.

Not sure how to do that. I’m just going to give up on SkyConnect. Thanks anyway.

Did you solve this? I am having the same issue on a fresh pi install

I’m having the same issue - did anyone get this working?

Is anyone able to get this working on a raspberry pi 4?