SkyConnect USB Device has very same Device ID as Aeotec Z-Stick 7?

Good evening,

I just got my SkyConnect, shut down my HA virtual machine and hooked it up to my proxmox server, passed the USB device through to said VM, started it back up just to find my Z-Wave network etc no longer working.

I was a bit confused, then checked the hardware configuration for the VM and saw that both USB sticks - the SkyConnect and the Aeotec Z-Stick 7 have the very same device id.

Does anyone know if this is a USB stick / firmware etc issue or is it rather a system (proxmox / vm) problem? Right now not entirely sure where to start debugging with this.


All of the Silicon Labs CP210x-based USB devices have the same device IDs. I’m not familiar with how Proxmox does USB pass-through, but it’s generally not a problem to use multiple of the same devices.

Did you actually confirm that the VM guest is missing the Z-Wave controller, or is your Z-Wave add-on configuration using an unreliable path like /dev/ttyUSB0? Make sure you’re using the /dev/serial/by-id paths for all USB serial devices.

If there’s some kind of limitation with the Vendor/Device ID selection in Proxmox, you could try USB Port instead, just don’t move the sticks.

1 Like

Evidently they both use the same serial chip.

Oh my, that was the problem… apparently I still had used the /dev/ttyUSB0 path type… switched over to the by-id one and now the Aeotec based Z-Wave setup etc still works as expected once the Sky Connect is plugged in. Thanks!

Helly guys,

I’ve got the same problem. I also tried to use the ports by ID.

Z-Wave JS ignores the choice by ID in the configuration and takes ttyUSB…

2023-06-10T20:56:38.496Z DRIVER   version 10.22.3
2023-06-10T20:56:38.497Z DRIVER   
2023-06-10T20:56:38.497Z DRIVER   starting driver...
2023-06-10T20:56:38.516Z DRIVER   opening serial port /dev/ttyUSB0
2023-06-10T20:56:47.557Z DRIVER   Failed to open the serial port: Error Resource temporarily unavailable Cannot 
                                  lock port
2023-06-10T20:56:47.558Z DRIVER   destroying driver instance...
Unable to start driver ZWaveError: Failed to open the serial port: Error Resource temporarily unavailable Cannot lock port (ZW0100)
    at Driver.openSerialport (/usr/src/node_modules/zwave-js/src/lib/driver/Driver.ts:1203:9)
    at Immediate.<anonymous> (/usr/src/node_modules/zwave-js/src/lib/driver/Driver.ts:1038:5) {
  code: 100,
  context: undefined,
  transactionSource: undefined
[20:56:47] WARNING: Halt add-on
s6-rc: info: service legacy-services: stopping
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped

any idea to solve this problem?

kind regards

Any chance you ever resolved this?

I just happened to run into this. It seems that by the grace of God(1) I was able to run these two devices concurrently for months, then I rebooted the system and one device disappeared and Z-Wave got the short end of the stick.

Even though I was passing through both devices in PVE, I was passing them in by the Vendor/Device ID. When Z-Wave stopped working, I noticed that its entry in /dev/serial/by-id had disappeared, and only the SkyConnect device was present.

In PVE I changed the passthrough from Vendor/Device ID to Port-based mapping and this allowed usb passthrough to expose both devices again. Rebooted the VM and now both devices are back in /dev/serial/by-id and Z-Wave is happy.

Hope this helps!

(1) used as a turn of phrase only, not endorsing any sort of belief system.

Thought I’d post here as it’s relevant to my issue (well, according to Google :slight_smile: ).

I’ve bought a Sky Connect and although I was building out a second instance of HA on an RPi to connect to it, I ran into unrelated issues, so I thought I’d see if I could connect it to my main HA instance (hosted on ESXi 7.0).

The Sky Connect wouldn’t show up in HA.

My VMware admin days are long behind me and I forgot that I needed to add the device to the guest OS. When going into the VM settings, even though the VM was powered off, the Add other device > USB device option was greyed out.

I’d checked the ESX host that it was connected:

[root@esx1:~] esxcli hardware usb passthrough device list
Bus  Dev  VendorId  ProductId  Enabled  Can Connect to VM                  Name
---  ---  --------  ---------  -------  ---------------------------------  ----
1    2    10c4      ea60          true  no (usbarbitrator is not running)  Silicon Labs CP210x UART Bridge

As can be seen from the output of the esxcli command, the USB arbitrator service was not running.

To start:

[root@esx1:~]  /etc/init.d/usbarbitrator start

And to make sure it stays running, even after a reboot:

[root@esx1:~] chkconfig usbarbitrator on

Now, running the esxcli command again:

[root@esx1:~] esxcli hardware usb passthrough device list
Bus  Dev  VendorId  ProductId  Enabled  Can Connect to VM  Name
---  ---  --------  ---------  -------  -----------------  ----
1    2    10c4      ea60          true  yes                Silicon Labs CP210x UART Bridge

And in the UI, the Add other device > USB device option was no longer greyed out:

The Silcon SkyConnect v1.0 device is connected:

And in HA:

Job done.