SkyConnect / ZHA Issues


I’ve just migrated my Zigbee network from Deconz / Conbee II to ZHA / SkyConnect and I’m having a bit of a nightmare. If anyone could help with an of the following issues I’m experiencing I’d be extremely grateful.

Firstly, I have end devices dropping off the network all the time. The worst culprits are 3 Hue motion sensors, two of them in particular. They just get stuck in a given state and the occupancy never updates again. This happens more than once per day per device. They start working again if I re-pair then the same thing happens a while later. I have one other Hue motion sensor that appears to be working perfectly. All motions sensors are on the same firmware.

I have a similar issue with Aqara door open sensors, although these can either stop sending state updates or just go unavailable. Again, re-pairing makes them work again for a while.

Another issue is that the SkyConnect sometimes locks up after a system restart and the ZHA integration fails to load. The only way to resolve this is to unplug and replug in the USB stick. This has happened twice in about 4 days. I updated the firmware after the second time so I’ll see if this improves it at all.

I tend to bind my switches to bulbs and I’ve noticed that the front end is extremely slow to notice a state change on the lights when they are changed via a bound switch, it can take over a minute for the front end to realise a light has changed state. This doesn’t seem to affect ZHA groups which become expose as entities, these appear to update instantly but unfortunately only groups with more than 1 device appear as entities so I can’t even work around this. Any way to force even groups of one to become entities?

For a bit of background I’ve had the network running for over 3 years with Deconz with the same Zigbee devices and I’ve not had any of these issues before, the network was quite stable previously. I have about 80 Zigbee devices on the network, about 40 are routers and 40 are end devices. Almost all routers are Hue bulbs with approx 5 Innr bulbs and smart plugs. End devices are either Hue motion sensors and switches or Aqara openclose / water / smoke sensors.

Is it likely that the instability is due to the SkyConnect or ZHA? Is changing to ZHA / Conbee II likely to improve the situation (i.e SkyConnect is to blame) or is it more likely the ZHA is causing the issues? I really don’t want to have to fail back to Deconz, it look me like two days to migrate everything across.

1 Like

Disclaimer, I don’t have SkyConnect, observations here are based on the ZBDongle-E based on the same SILabs EZSP chip. Observations are anecdotal based on my personal experience and testing. That testing has been rather methodical, but limited to my home environment. It is impossible to know what is a sonoff specific vs generic ezsp issue. All comparisons are against a ZBDongle-P (TI cc2652 chip). Overall I’m under impressed with the ezsp stick. In my testing the cc2652 stick seems the better behaved. But again, anecdotal.

Try lowering the output of the coordinator. I’d try +5db to start. I’ve just about convinced myself the EZSP +20db default is problematic and confuses end devices more than it helps. I imagine the issue is exacerbated with SkyConnect’s small pcb antenna.

The ezsp stick seems more sensitive to interference for me. Did your zigbee channel change from deconz? Is placement comparable? Have you evaluated for local rf conflicts?

There is an ezsp config option to prevent end devices from connecting directly to the coordinator. In a router rich environment like yours, I’d be curious if it helps.

With migration without re-pairing relatively simple in ZHA, I’d be very interested to know if swapping a cc2652 stick in helps or hurts. If ZHA can migrate the to the conbee stick, I’d also be curious.

I’ve had a different issue migrating my ZHA mesh from a ConBee II to a SkyConnect - the 87 devices on my network all stayed online without issue, but pairing new devices is impossible.

Following my normal process for adding a new device I open the mobile app, go to Settings > Devices & Services > Add Integration > Add ZigBee Device.

I then put the new device in to pairing mode and the app shows the Device Found card with the blue header, and takes 2-10 seconds to go through to finish interviewing and initialising the device (battery powered devices take longer than, mains powered) and shows me the “Device is ready to use” card with the green header, but the device doesn’t exit pairing mode and a few moments later device drops off the mesh. It will re-appear 2-10 seconds later.

If the device is unavailable when ZHA’s pairing session times out, the device remains unavailable, even if power cycled.

I have tried powering off the device as soon as it pairs successfully and waiting for the ZHA pairing session to time out then powering up the device again, but the device remains unavailable.

I tried waiting until very late in the ZHA pairing session before putting the device in to pairing mode in the hopes that it would remain paired if ZHA closed the pairing session, and after about 30 attempts managed to get it to remain on the mesh for an extra 5 seconds, but it still went offline after that.

I tried rebootiing my HA container, no dice.

I tried shutting down HA, unplugging the SkyConnect and power cycling the device, the plugging the SkyConnect back in, then starting up HA. Didn’t help.

Finally, after the 4th different device failed to remain paired I migrated back to the ConBee II and successfully paired all the devices that had failed.

I haven’t got any logs I can share at the moment, but can enable debugging for all the ZigBee components and collect them if it would help.

I got my USB 10’ extension cord today and I was able to connect the devices.