SkyConnect & Zigbee2Mqtt

Thanks…I played with this some more, including your suggestion, and it now works :slight_smile:

1 Like

Also recommend read and follow this very related discussion about migrating between different adapters in Zigbee2MQTT → https://github.com/Koenkk/zigbee2mqtt/discussions/16478

Is the config for your multi-pan set to the defaults?
I’m unable to get it working, also on Home Assistant OS. So was wondering besides a reboot, is there anything else you’ve done.

Yeah, I think the only setting I changed was that I toggled on the “Enable OpenThread Border Router web interface” setting but I don’t think that would have made a difference.

Baudrate is set to 115200 which I’m pretty sure is the default. You made sure the silicon labs addon is running and that the host name for it matches what you are using in the z2m config?

Yup, it’s picking the connection up in the multipan addon logs, but zigbeed eventually crashes and restarts when z2m makes the initial call. :frowning:

My multipan addon config seems to be the same as yours. Any other config on z2m side for you?
If all else fails, it could just be an issue when the device is passed through my VM.

1 Like

Not really, I think the only real setting change in z2m from the defaults was changing the channel to 20.

I did also have everything setup and working originally using the factory firmware and setting the adapter to ezsp and the port to the skyconnect usb path. It was only after everything was setup and working fine that way that I enabled the multi-pan and changed the port in the config and then rebooted everything. Also, most of my devices didn’t show back up on their own but repairing them did the trick.

Hmm same config as you have here. It might really be due to VM passthrough. I’ll try when I get hands on some new hardware and when the family is out. :laughing:

Thank you so much btw!

1 Like

Hiya guys

Love the community and the assist. Recently jumped into the HA world. Only had a wifi plug till now.

I ordered Skyconnect stick and finally got it. The goal is to keep everything local but trying to learn HA, integrations and addons is doing my head in. Installed HASS on my new 13th gen build using VirtualBox.

I had a major headache setting up skyconnect without any idea how things worked. As I understand there are three crucial standards I would like to deal with Zigbee, Wifi and Bluetooth maybe
I was thinking of buying zigbee only devices from now on to keep it local and not having to flash anything but thinking I might not be understanding smart stuff since I only recently started looking into things.

Please note - Goal - keep everything local since somehow got Zigbee2Mqtt Siliconlabs Multi protocol working and have some questions if may…
do sticks like sonoff and skyconnect need to be flashed? If so why?
do zigbee devices need to be flashed for any reason?
I was reading a while ago most wifi devices(sensors, switches etc) can be flashed until tuya updated the firmware. How would I know if something is flashable before I buy?

I can say that I have successfully migrated my Zigbee network over to SkyConnect (Multiprotocol) and Zigbee2mqtt. I am running HA supervised via docker. It requires you to remove your previous configuration.yaml in the zigbee2mqtt folder (rename it with a .bak extension so you don’t lose it all). In the Zigbee2mqtt Addon configuration, under serial, add the following:
port: tcp://core-silabs-multiprotocol:9999
adapter: ezsp

Restart the addon, and poof, it ought to load.

You can then drop the entity contents of your configuration.yaml.bak file into the configuration.yaml file. When you re-pair your devices, they will repopulate with their friendly names and any associated settings previously established.

I am running Philips Hue outdoor lights, Philips Hue indoor and outdoor motion sensors, and Aqara temperature/humidity sensors. They all paired promptly and without issue.

Hope this helps!

3 Likes

I am trying to get this working on HA Truecharts. I am following this guide, but Zigbee2Mqtt won’t deploy. The logs show this:

Using '/data' as data directory
Zigbee2MQTT:info  2023-02-26 17:04:01: Logging to console and directory: '/data/log/2023-02-26.17-04-01' filename: log.txt
Zigbee2MQTT:info  2023-02-26 17:04:02: Starting Zigbee2MQTT version 1.30.1 (commit #eb878d3)
Zigbee2MQTT:info  2023-02-26 17:04:02: Starting zigbee-herdsman (0.14.89)
Zigbee2MQTT:error 2023-02-26 17:04:02: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-02-26 17:04:02: Failed to start zigbee
Zigbee2MQTT:error 2023-02-26 17:04:02: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2023-02-26 17:04:02: Exiting...
Zigbee2MQTT:error 2023-02-26 17:04:02: Error: Error while opening serialport 'Error: Error: Is a directory, cannot open /dev/ttyUSB0'
at SerialPort.<anonymous> (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/znp/znp.ts:146:28)
at SerialPort._error (/app/node_modules/@serialport/stream/dist/index.js:76:22)
at /app/node_modules/@serialport/stream/dist/index.js:112:18

Any ideas? I am slightly new to Linux and can’t find configuration.yaml to add the “adapter: ezsp” to it, but I am not even sure if that’s the solution to my problem.

I just upgraded to 1.30.2 and now can no longer get it to work with multipan. I wanted to ask if anyone else is having this problem?

[UPDATE} I just downgraded to 1.30.1 and it works again.

1 Like

was working perfectly and now its broken after update for me too.

I just received my Skyconnect and want to setup a new Z2M network (multipan) while maintaining my ZHA (Conbee 2). The challenge is now: how to get my hands on zigbee2mqtt 1.30.1?

I can’t save this entry, because of the message when I try to save the addon-configuration:

“… does not match regular expression ^zstack|deconz|zigate$…”

For me, I find that 1.30.1 works most of the time with multiprotocol Add-On 0.13.1, but I find it doesn’t always work (sometimes I have to restart several times). I’ve tried different combinations: 1.30.1 doesn’t work with the newer AddOn 1.0.0, and 1.30.2 doesn’t work with any versions of multiprotocol Add-On.

I just started this some hours ago and I have a conbee II with deconz and wanted to start migrating to zigbee2mqtt with my new skyconnect. As I just started Im on 1.30.2…So how do I downgrade to 1.30.1 to get this working. Im using a HomeAssistant Blue.

how did you downgrade?

I did in HA as long as you made a backup before upgrading:

Settings > System > Backups

Then restored the latest backup (automatically made by HA)

Hope this helps

(
PS after I downgraded, I was able to get it started by using:

port: tcp://core-silabs-multiprotocol:9999
adapter: ezsp
)

Does anybody who enabled the multipan since last 2023.03 release have an increased cpu and power consumption of home assistant?
I am running ha on a intel nuc i7 (very overpowered) and since the latest the update the fans are noisy all the time and the attached energy meter measure a hight powr consumption.

Addon itself has 12.5% cpu consumption.
All my other addons (influx, grafana, zwave, have no more then 0,1% cpu usage)

It looks like there is a fix in the works getting zigbee2mqtt working with multiprotocol again.
The latest “Edge” version of the zigbee2mqtt Add-On has the fix if you want to give it a go.