SkyConnect & Zigbee2Mqtt

That setting for the coordinator device reminds of two old (and probably no longer PC) comedy skits :wink: :

Spinal Tap … turn it up to 11.

Garrett Morris … news for the hearing impaired.

Hi all, since I want to use a TRV602 with Zigbee (not supported by SkyConnect v1.0) I want to switch to Zigbee2MQTT using my SkyConnect stick. Is that easily possible?

This worked for my SkyConnect too, thank you so much!

Hello everyone!

I have been trying for days to get my SkyConnect to work with Zigbee2MQTT on my HA Running in docker on my Synology NAS.
I installed the USB Drivers and ZHA works (using ttyUSB0)
(NOTE that i have disabled ZHA before trying MQTT).
But I get the same error as everyone here.
I tried both the

serial:
  port: /dev/ttyUSB0
  adapter: ezsp

and the

serial:
  port: tcp://core-silabs-multiprotocol:9999
  adapter: ezsp

Configs but neither of these work.
I cant figure out device ID or use the add-on as I am running HA in a docker and cannot run HomeassistOS.

Any help would be greatly appreciated!

Hello @SimeJah

You cannot use the same device on both HA and Z2MQTT

If your SkyConnect is already been used by HA (using ttyUSB0) you cannot use it in Zigbee2MQTT, you will need a second device.

That being said, if I didn’t understand you right, the correct configuration to use your SkyConnect would be:

serial:
  port: /dev/ttyUSB0
#  ezsp was/will be deprecated
# don't set any value here, Z2M will use the default value (ember)
#  adapter: ezsp 

Hope this helps