Slack: Identical config works on raspi but not VM instance

I have two different HA instances. One at home (running on a raspi) and one at work (running from the HAOS vmdk). Both are running 2022.10.5 and OS 9.2. The only difference (besides the integrations used) is that my raspi instance has nabu casa enabled, and the VM does not.

On my raspi instance, I was able to configure a slack integration via the UI without a single problem - just pasting in my oauth key and default channel. But on my VM instance, the integration won’t start, and I get the following error during setup of the component:

Logger: homeassistant.setup
Source: components/slack/
First occurred: 10:58:30 PM (1 occurrences)
Last logged: 10:58:30 PM

Error during setup of component slack
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 235, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/slack/", line 29, in async_setup
    if entry[CONF_PLATFORM] == DOMAIN:
TypeError: string indices must be integers

I’m not sure what could be causing this to work on once instance and not the other. both machines can reach slack without any firewall issues, both have a very similar route to the internet, and both have the same config.

I even went to /config/.storage/core.config_entries and compared the entry between the two machines, and the only differences in the entry are the entry ID key.

        "entry_id": "33366e47be802f3da317bb489ac1dfb6",
        "version": 1,
        "domain": "slack",
        "title": "myslackserver",
        "data": {
          "name": "myslackserver",
          "api_key": "xoxb-00000000-0000000000000000000000000000000000000000",
          "default_channel": "#general"
        "options": {},
        "pref_disable_new_entities": false,
        "pref_disable_polling": false,
        "source": "user",
        "unique_id": "t024ke96l",
        "disabled_by": null

The entry was successfully populated with the name of my slack server, so it’s successfully pulling that data, but I just can’t get the integration to start.

Is there anything else I can do to further troubleshoot this? Thanks for your help!