SleepIQ integration not working

Any other Sleep Number users having issues with the sleepiq integration not recognizing their username and password all of the sudden? Double checked credentials and they work elsewhere.

2020-11-19 08:50:05 ERROR (SyncWorker_13) [homeassistant.components.sleepiq]

SleepIQ failed to login, double check your username and password"

2020-11-19 08:50:05 ERROR (MainThread) [homeassistant.setup] Setup failed for sleepiq: Integration failed to initialize.

Same exact issue here after upgrading to 0.118.0. I logged out of the app and was able to login with same password setup in the HA config just to rule out an authentication issue on the sleep number side.

Tried moving the config around in the config file in case of a timing issue, but no effect.

Glad to know it’s not just me. I rolled back to 0.117.5 but still the same issue. Thinking maybe something changed on the SleepIQ API side.

Glad you posted. I was getting ready to roll back. You saved me some time. I suspect you are right. I have noticed issues with SleepIQ being available over the last few days even when in the IOS app. Hopefully someone submits a fix. I really love this integration.

Me too. I use it in quite a few automations. I would be really sad to see it disappear.

1 Like

I was just about to open an issue on github, jpenrodST beat me to it.

1 Like

Do you have a link to the issue? I’d like to track it.

Duh, sorry, you included it. I looked right over that. :slight_smile:

Same issue here. Hope it gets fixed soon. Until then I guess I will set an input boolean to trigger my bedtime routine, or go back to using my Withings Sleep.

Issue raised on the sleepyq library github.

I’m having the same issue. I read in another thread a comment that someone working on the Sleepyq python library had to sign a non-compete and had stopped developing it.

Like others, I hope this doesn’t go away. A chunk of my automation depends on it.

Oh. There are already comments on the issue with a potential fix. w00t!

So, I tried the recommended fix and it still fails. I’ve updated the issue in github; however, things don’t look promising as I stumbled across this item from five days ago:

It appears the SleepIQ servers are being overwhelmed by the API calls and they’re requesting that integration points be disabled.

Sad day indeed! :sob:

Okay, the Github issue now has a manual fix. Apparently, they only started checking the user agent.

1 Like

Manual fix is working! I see a PR was created. I’m a total Github newb so I’m not sure what that means as far when the actual integration will be fixed.

So I’m wondering if their infrastructure is getting slammed by the number of API calls, do we need a feature to limit how often we check for a status change? I saw MyQ do this same thing where they started blacklisting IP addresses. I’m sure we don’t want to get to that point. I could most certainly live with checking less frequently if it keeps the integration alive. Thoughts?

Does anyone know where this file is located in Home Assistant Supervised? I don’t have a site-packages folder in /lib/python3.7. I’ve searched for the sleepyq folder and it doesn’t appear to exist.

If you haven’t gotten it already try /usr/local/lib/python3.8/site-packages/sleepyq

Tried that but there is no site-packages folder. I searched the entire file system for the sleepyq and that folder doesn’t exist.