SlimmeLezer seems to block Energy Provider to read data

I’ve been using the SlimmeLezer for the last couple of months and it works great in my Home Assistant setup. The only hiccup I’ve run across is that my Energy Provider hasn’t been able to read data from my Smart Reader. Since a couple of days I’ve disconnected the SlimmeLezer from the Smart Meter and now my Energy Provider is once again able to read data.

It isn’t really a problem as I can manually give them the readings, but it is inconvenient; has anybody else run into this problem?

I’m experiencing something similar… I can’t confirm this is the true cause, but in the whole street I’m the only one using Slimmelezer and only at my meter the provider is unable to readout the values on regular basis (roughly since the timepoint I installed Slimmelezer). Their system shows the data for a couple of days and then my meter just kind of disconnects. Not sure what they do then, but after a day or two they can read it again, but then in a couple of days it goes offline again and this repeats all the time.
In HA it works perfect all the time.
Maybe the constant read signal on the local port from Slimmelezer is just too much to handle for the meter and therefore after a certain time period it “freezes” the providers communication channel?

This also seems to be the case with my meter, when I went back to check I can see a couple of days on which they were able to read data, but others not at all. And indeed, Home Assistant has a complete history available.

Maybe there is a way to decrease the reading of data and let the Provider read it; when I get a chance I’ll look into the code

I guess you can’t change that, because the read request in Slimmelezer is always “high” AFAIK. The read request pin is namely connected directly to +5V.
I was already thinking about changing that (I’m using alternative firmware called SHRDZM, which supports read request on a defined pin), but was unable to phisically change the connection on a PCB… but truth to be told, I didn’t put much effort in it :).

1 Like

@florisvdsande, @AdmiralStipe has this issue been resolved for any of you?

@florisvdsande, what meter are you connecting the SlimmeLezer to? By any chance, is it an Iskra AM550, like what @AdmiralStipe has?

Generally not, I guess, but I just checked and my provider has non-interrupted data flow from 23.3.2023 until today… so at least last couple of weeks the issue is not present.
Still I believe, that reading of the P1 port only at certain intervals would be better, but Slimmelezer’s wiring does not natively support that and I still didn’t try to solve it by myself, as I don’t have big problems because of it, only my provider does :slight_smile:

Which version do you have? The Plus version? And which revision of the board?

It’s the original (old) one, not Plus. The board version is v1.1.1…
I know it’s not too hard to break the connection on pin Nr. 2 of the connector with Vcc and attach it to one of the pins for the Data Request signal, but normally I tend not to repair something, that basically works… as it may not work anymore later on :).

1 Like

Thanks! I confirmed with Marcel that the enable pin is hot wired to 5V on the Plus model as well. Version: 1.2

Funny though…

I am just reading the regulation of the Netherlands regarding those Slimme Meters there, including the Iskra AM550’s local version.

I assume @florisvdsande is from the Netherlands.

5.5.1 Avoidance of influencing the Metering System through P1 port It must not be possible to influence the Metering system in any way through the P1 port (except from requesting and receiving data, and getting +5V power supply as specified in section 5.3). Especially it shall not be possible to interrupt or block in any way the other modules/ports/ parts of the Metering System (i.e. by maliciously manipulate the “Data Request” line). See also section 5.2.2 – Galvanic isolation.

So the meter should be protected against this kind of issues.

Just now I saw your replies, and you are correct, I am from the Netherlands.

Last month I had a problem with ESPHome en reflashed all my devices including the SlimmeLezer; and now looking back at the data from my energy provider, everything seems to work again!

I flashed it with the latest version of the firmware from Marcel Zuidwijk. Either the reflashing, or plugging it back in, or something else, caused it to function properly again.

Thank you for your responses

To be honest, it should not effect the GSM/LTE data transmission, unless you placed the module on the top left part of the meter where the GSM/LTE module is inside and causes interference and cannot get a proper reception.
It is not allowed to modulate the request signal which could be a source of a this kind of issue, but the module has a hard wired 5V on the request signal and the ESP cannot modulate it (by turning it on and off or anything).

So there shouldn’t be any reason to cause any issue with the GSM/LTE data transmission, but the top one with radio interference.

1 Like

Then that’s exactly what happened… :sweat_smile:
I initially had it on the top left of the meter, but since the re-flash I just have it hanging down the side.

Thank you for sharing your knowledge!

Now I just need to add a sticker or something to remind myself about this…


@AdmiralStipe, what is the situation with your module? Where do you keep it?

Many P1 readers has a really short cable like the HomeWizard, so there isn’t any chance that would interfere with anything.

1 Like

I live in an older building, where the meters are mounted in tin boxes in the wall (separately for each flat). Inside these tin boxes there is no Wi-fi signal (they act as Faraday cages), so I had to get a longer cable from Aliexpress and I now have the Slimmelezer mounted on the wall just outside this box… well on the box frame actually :smiley: .

That’s explains why they might not have mobile reception there.