Slow ethernet network traffic with RPI4

Hello, i still have trouble configuring HA.
Im running the latest version (11.1.) with a Raspberry Pi and ethernet connection. With the pi connected, my WIRED traffic in the whole network is super slow and unstable. sometimes less then 5mbits, sometimes 300+mbit ( i have a 500mbit cable imtermet). howerver, my upload is totally fine!, and my wifi devices still recieve the maximum download speed.

i tried everything, changed cables, ports at my router, i even bought a second RPI4! i backed up the files and restored them on the second pi, installed HA multiple times, but the network problems stay the same. on my old RPI 3B+ everything is fine!!! i use the offcial raspberry power supplies and disabled eee (efficient energy ethernet), but it didnt help. can someone PLEASE help me? the problem is now really frustrating and desperating me, i spend hours and days on this problem, but i have no clue why this happens and how to fix it :frowning:

i use a fritz!box 6590 cable router btw.

Why not consider getting a miniPC (x86-64) from any of these companies: or or any other vendor of your budget choice.

You will be trouble free not having to worry about power supplies, SD cards, etc.

You could also find a wealth of information consulting my guides on HA HW. For trouble free HA experience only the x86-64 platform provides the robustness required, while providing an abundance of choices.

Using Pi won’t cause this issue and Pi is fine. I do recommend PC if not budget related choice.

I see a post where integration cause network issues. Have you tried disabling all integration and testing in this condition. Basically run HA with default config. I think you can disable them in settings >> devices & services as well.

Other possibility is Pi using another device IP but I don’t expect that affect whole network, maybe single device.

Well, i dont wanna spend this much on a mini pc device. i also like the low power consumption a rpi has. but thank you for your tip :slight_smile:

like tmjpugh said (dont know how to quote two replies in one post), a RPI should be fine. everything works fine with my RPI 3b+, so why this problem occurs with the RPI 4?

i’ll try with disabling all the devices and will post the result here. thank you too!

sorry. missed this fine point about 3b working and 4 not. this may be significant.

Have you tried with wifi on Raspi4?
Is IPV6 enabled on pi or router? Try disabling on router.

Triple check the RasPi power supply.

Okay, im running the pi via wifi now, at now my traffic is fine. i have no idea why the ethernetport causes so much trouble.

i was too euphoric about yesterday. even with wifi, my internet is significant slower, but on a more stable level.

i’ll try the solution you’ve linked, but i’m sceptical…

but thx anyway :slight_smile: