Slow onkyo - Pionner commands

Hello everybody!

I’ve setup my home assistant installation to control my Pioneer SX-S30DAB.
Everything works fine but its really slow to apply settings (change source - volume - power on - power off ect…)

As a point of comparaison, i had it intergrated with Domoticz and it was near real time when sending command for it to be applied using onkyo-eiscp

With home assistant it may take 5-10 secs for a command to be applied.
I also have this kind of messages in logs:

Is there anything i can do to improve response time? Do i have to change some settings?

Config. yaml looks like this:

  - platform: onkyo
    host: fqdn
    name: Amp. Salon
      bd: 'PC'
      TV: 'TV'
      bt: 'Bluetooth'
      strm-box: 'Switch'
      video2: 'Recalbox'
      cd: 'Moode-Audio'
      phono: 'Platine'

Thanks for your help
kind regards

I have the same problem since updating to 0.109.6. My amp is the Integra drx2 which uses the same onkyo-eiscp platform as OP.

1 Like

The update to 0.115.x really slowed it down for me., and now takes 5-10sec It wasn’t perfect before, but much faster than now.

Has anyone found a solution?