SMA inverter can't connect

Hi everyone

Im trying to connect to my SMA solar inverter - but no luck

Every time I type in the IP address an code it just says failed to connect.

I have tried both with SSL and without.

The integration says SMA US - Is it because its only Inverted in the US it works with - Mine is in Denmark.

I have searched in this forum but can’t seem to find the answer.

I have no problem to connect with SMA Solar portal

Im using HA core-2022.4.4


What model inverter?

The settings I use for my SB6.0 are:

Uses SSL certificate → true
Verify SSL certificate → false

Hi Tom

My inverter is an STP 6000TL-20

I can’t find anywhere I can change SSL settings int Sunny Portal so therefor I tried very combination without luck.

I have a SMA Sunny Webbox that I can access from my local network using
It’s also been configured to update the SMA Sunny Portal.
Both methods work fine.

I’ve tried the SMA Solar integration and I have the same issue as the OP.

I’m running Home Assistant 2022.4.6 on a RPi 3B.
It’s on a reserved IP address and can talk to my Tasmota devices and has internet access.

The integration only connects to inverters with WebConnet. If you search the forum people have been using Modbus for other inverters.

Hi @tom_l
Didn’t know the SMA integration is not for communicating with the SMA Webbox.
For those who didn’t know, I found this :

In my case do I need to buy more hardware to connect to my Sunnyboy inverter?

I know I can program the SMA webbox to FTP push CSV or XML files with regular PV output info. so I’m speculating I may be able to use this function?


SMA Inverters block connections coming from the DNS server. If you’re using something like PiHole or AdGuard in hassio: update the settings of your inverter (manual ip address, set DNS to something else).
This has worked for me multiple times.

Hi - I have same issue as edd30 - I tried everything no luck. I am not using AdGuard nor PiHole. “What do you mean by set DNS to something else…” ? Any help appreciated !

Hi edd30 - Were you able to fix the issue? Thanks