Smart bulbs turn on by themselves

Hello.

I have a problem with some of my Ikea Trådfri smart light bulbs that turn on randomly by themselves with the log saying for example: “Turned on triggered by state of ‘Bulb Name’ turned on” or simply “‘Bulb Name’ turned on”.

In all other instances the log shows either that the light is triggered by me or a motion sensor or by an automation. But in these instances it doesn’t say, what triggered the turn on.

I’ve tried deleting the database, switching the bulbs to other sockets (in case it was short power losses) and even repairing the entirety of my devices from scratch in Home Assistant, but nothing helps…

I’m running Home Assistant on a Home Assistant Green with the Sonoff ZigBee dongle plus E with an extension cord, and i have around 25 light bulbs where most of them are Ikea Trådfri and around 25 Sonoff Motion sensors, door sensors, temperature sensors and 6 Sonoff Thermostatic Valves.

I’ve included photos down below and if you require additional info, don’t hesitate to ask. All help is gratefully welcome!

I’ve done some testing and it seems to be the automation itself turning the bulbs back on after turn off. (See included photos)

EDIT: The problem jumps between all lights in my home and the automations are so simple so I rather think the whole ZigBee Network is unstable and therefore causing the issues.


if you haven’t figured out the bug in your automation, post it and maybe we can help…

1 Like

It seems to be unstable ZigBee Network. Although i live far from neighbours (possible wifi interference), have set my own WiFi channels far from ZigBee channel, used long extension cord with my dongle, used USB 2.0 port and pretty much done everything else in regards to negate interference on ZigBee, it still acts very weird and unreliable.

In the following month, since my last post, end devices have become unavailable daily, several lights around the house turn off again right after they have been turned on by motion, and some lights either turn on at a different percentage than defined by the automation or doesnt turn on at all.

My next move is to buy another dongle (smlight zb-06) to try and improve the whole setup, as it seemed to work for Home Automation Guy on YouTube.

Something else to try instead of a new dongle may be to add multiple redundant routes and shorter hops by putting in relays. Get a few zigbee outlets that serve as relays. If you look at your zigbee map and you see single routes to each end point and the lqi is not great to each, redundancy and shorter hops is most probably the better solution

Also, the sonoff dongle e allows you to change the power level it uses to transmit. You might try increasing that.

1 Like

Thank you. I will try that. In frustration I migrated to ZigBee2MQTT as well - which is something I’ve been wanting to do for a long time. For some reason all my devices seem to have a higher lqi now, than they did before. I assume it’s because I could more easily choose how to build my ZigBee Network in regards to connecting devices, than I could I ZHA.

How do I change the transmit power of my e-dongle?

Many thanks for your time🙏🏼

if you deem that the issue is the distance from your controller to the network, then i’d try this before having a super long usb cable. however remember that all you need to do is to get connected to a stable connected part of the mesh. doesn’t need to be in the middle.