Smart things token error

Hey All, I’m trying to add Smart things in to my home assistant, but I got some problems with the token. When I generate the token on the Samsung website, hassio gives me the error that it needs an UID/GUID format. Maybe someone can help me?

Are you using Nabu Casa or not? In which step did you get this error?

I don’t use Nabu Case, the step can you see on the screenshot.

Are you sure that your token starts with https:// ? The tokens I know are some long string of letters and numbers something like jfud7fx5e9e5vn5v6d777xujjf........ did you follow the instructions in the docs?

Hi, I am sure that I use https:// the token I get from smartthings site is an lang strip with “-” between a couple of numbers and letters. When I delete the - it stills doesn’t work. I followed the instruction and I have watched a few tutorials on Youtube and I can not find some differents.

You need to put that long string in there and remove the https:// in the beginning or is https:// part of this lomg string?

When I remove the https:// then I get the error that it needs an https:// url. It is not part of the long string, I added it by myself.

You entered the token generated in the dialog, pressed “OPSLAAN” and then it gave you an error that you need https://?
Can you please show this error message that tells you that you need https://?

Are you able to access Home Assistant remotely?

yes I am able to acces my hassio remotely. Here 2 screenshots of the errors.

The second one is the way to go. It doesn’t say that the access token needs to start with https://

In your configuration.yaml there’s a section starting with http:, you need to change or add the base url in this section so that it looks like this:

  base_url: https://your-url-for-external-access

Then restart Home Assistant and enter the generated token again.

I’ve added this line in to my configuration.yaml and I restarted hassio, but now I got a new error (SmartThings could not validate the endpoint configured in base_url. Please review the component requirements.). Is it maybe because I just use the port forwarding method and not something like duck dns?



Do you have a static IP for your router or how do you get the current IP address when you are outside your home?
Did you still get the same error from the second pic?

I have an port forwarding rule in my router (I think that is an static IP) Here is a screenshot of the error. image

If you are outside of your network what do you enter in your browser to access home assistant? (this is not the real ip-adress)

Hi Burningstone, I’ve added DuckDNS to my home assistant, this was the solution! Thankyou for your help!

1 Like

Good afternoon
i can’t tune smartthings is giving the following error.
can someone help me.
and also I can not connect home connect

SmartThings could not validate the webhook URL. Make sure the webhook URL is accessible from the internet and try again.