Smarthings Integration into Hassio giving "base_url error"

I have been trying for the last couple of days to get SmartThings onto Hassio. I have successfully setup DDNS with SSL (through DuckDns & NGINX), but whenever I enter the Personal Access Token for SmartThings Integration I get the The base_urlfor thehttpcomponent must be configured and start withhttps://. error. Here is my configuration:

configuration.yaml (have tried different variations of the base_url)
base_url: “https://domain
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

duckdns config:
“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
“token”: “”,
“domains”: [
“seconds”: 300

nginx config
“domain”: “domain”,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“hsts”: “max-age=31536000; includeSubDomains”,
“customize”: {
“active”: false,
“default”: “nginx_proxy_default*.conf”,
“servers”: “nginx_proxy/*.conf”

What should I do to fix this?

I’m having the same issue.

I opened a github issue for this Smartthings token not accepted due to base_url · Issue #24523 · home-assistant/core · GitHub

Not a Nabu Casa user. Not the same issue.

1 Like

I doubt you’ll ever find or get an answer to this as I have yet to find one in my 2 weeks of searching and trial and error in the app. I found one post that said to # the http: statements in configuration.yaml - I did this and still couldn’t integrate, but could access home assistant via https;// I also tried to just # the ssl statements so that there was an https:// in the url. Still get error " The base_url for the http component must be configured and start with https://. Configuration.yaml seems to be the key, but how many different ways can there be; none that I haven’t tried. I’d bet?
Good luck.

This is a fairly basic configuration problem/not following the instructions. In configuration.yaml you must have the following:

  # Must start with "https://"
  base_url: https://....

You also need to restart Home Assistant any time you change this file or the changes will not be picked up.

Sorry I didn’t return to say that I am up and running. Apparently, http: was indented a space and then I indented base_url:https://XXX two additional spaces. Once I put http: on the extreme far left (no indent) and then indented other comments at 2 spaces it worked. Hope this helps. I thought I had tried all combinations of everything, but I think the http may have had the # in front to comment it out (??) and I substituted a space.

1 Like

Hi @DaveW1

I have Home Assistant 0.104.3 with Duck DNS and NGINX SSL/TLS proxy. Everything works super fine (DigiCert SSL certificate checker says it is correctly installed).

Recently I tried to integrate SmartThings and came upon the same error as you. I checked my configurator and indeed the indentation was off (please see below).

So I moved the “http:” block one space to the left (as below)

The problem is, after changing the indentation (to the supposedly correct format) I can no longer access my Home Assistant instance (neither via Duck DNS nor directly through IP address)

Any tips on this one?
I appreciate it mate.


Sorry I didn’t get back to you. I might have had the same problem - not sure but in any case I lost access one too many times and abandoned Home Assistant until a few weeks ago. Still having trouble, but I’m an expert on installing in different environments. Just none stay stable especially trying to get DuckDNS to work again. Trying to use Nabu Casa now, but it’s not even doing what I want. Supposedly I can send push notifications to the Android app but have wasted hours trying. I’m sure it’s simple, but maybe a space or comma missing and that’s all it takes.