Smartplug stopped working after running test automation

I just started using Home Assistant. I have purchased 5 of these plugs: Tuya Zigbee 3.0 Smart Plug Socket EU 16A, and added them to my HA using Sonoff Coordinator with ZHA.
They all imported well, and the sensors and switches worked well. I then made a test automation’s in Node RED, and that apparently broke the plugs (or the integration). It was just a simple automation using Event state on the Electricalmeasurement sensor, and then turn off the plug when the current consumption was below x Watt. The automation worked while testing it with only debug nodes. But after running the automation once with a “Call service” switch turn_off, the plug stopped communication with HA. No more sensor data, and the switch command didn’t work any more. I tried to “reconfigure device”, but that didn’t solve the issue. I broke 2 out of my 5 plugs before I realized that it was the automation call that “broke” them. I have tried to remove one of the plugs from HA, and put it into parring mode again, but the device is not being discovered again, when I search for new devices.

Anyone help will be greatly appreciated?

What was the load placed on the switches?

5 - 60 Watt

I think we can rule out overload then :wink: Its hard to believe simply operating it would kill the device, unless it was caused by the load itself. But apparently I’m mistaken.

Often, before devices will allow pairing again they need to be reset. Usually this is unplugging for more then 10 secs plugging it back in and holding the button for a long time (10 secs or so). Have you tried that?

Hi again,
First, thank you for trying to help me with this issue.
I’m 100 % positive I didn’t overload them, and I think you are right that they are probably not broken.
But I have tried to unplug (more than 10 secs) and also holding the button for 10-15 secs when plugging them in again. That does seem to put them in parring mode as they then start to flash. But HA still doesn’t pick them up again.

I’m not a node-red user, but could it be the automation is flooding the device with off commands because consumption is always below the specified level when off? Have you tried disabeling the automation?

Yes, the automation is disabled. I’m also pretty sure it wasn’t flooding the device as the event trigger only triggered when the consumption value changed, and that value was pretty stable

Just an update. I have still not been able to solve the issue. I have firmware updated my Sonoff Coordinator stick (ZBdongle-P) and have migrated from ZHA to z2M. My two “dead” plugs flash the paring mode signal when I power them on, but are still not being discovered. My 3 remaining plugs still works, and I have firmware updated those plugs using OTA update in Zigbee2MQTT. I have been looking for a way to firmware update the 2 dead plugs, but haven’t found a solution. The model number printed on the Plugs are: NAS-WR018. In HA they are recognized as TS011F_plug_1.