Smartthings - base_url issue


I am attempting to configure the SmartThings integration, but I’m running into a wall.

My setup is:

  • Hass.IO docker installed on dedicated VM
  • NGINX on a separate VM
  • SSL Certs configured on NGINX for my Home Assistant subdomain, acquired certs using Let’s Encrypt

My http component in configuration.yaml is:

   use_x_forward_for: true

Checked that SSL is working using which showed everything good (all checkmarks, correct public IP, correct cert expiration dates)

Enabled debugging for the smartthings component, which shows:

2019-07-23 18:57:27 DEBUG (MainThread) [homeassistant.components.smartthings.smartapp] Setup endpoint for

Which shows the internal IP for the home assistant VM and port, not the configured base_url from the http component.

Checked my settings in NGINX to match the “known to work” config from the troubleshooting page.

I’ve also been searching around and can’t find anything to help. Any ideas?

Just in case anyone finds this and is similarly scratching their head, my issues were:

  • My Home Assistant Config was invalid (the http section), but the validation check was claiming it valid
  • The entire http section was being skipped because it started with a space
  • After removing a single whitespace from the beginning of each line in my http section, I got a new error that was very cryptic, saying some but not all values in the same group were invalid
  • No idea what that was supposed to tell me, but the issue is the line saying “use_x_forward_for” which should be “use_x_forwarded_for”, note the ed on the end of forward

After saving and restarting, everything now works.